aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-05-05 18:42:48 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-05-05 18:43:13 +0200
commit962543ffdb846b9ea64b31917171d1dcb23e69d8 (patch)
tree2dea9a127e63a60f0b694a80517c6513d09e0ac1 /mpv-plugin
parentdev-lang/hare: Add MPL-2.0 in LICENSE (diff)
downloadguru-962543ffdb846b9ea64b31917171d1dcb23e69d8.tar.gz
guru-962543ffdb846b9ea64b31917171d1dcb23e69d8.tar.bz2
guru-962543ffdb846b9ea64b31917171d1dcb23e69d8.zip
mpv-plugin/mpv-mpris: move from media-video/mpv-mpris
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'mpv-plugin')
-rw-r--r--mpv-plugin/mpv-mpris/Manifest2
-rw-r--r--mpv-plugin/mpv-mpris/metadata.xml15
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-0.7.1-r1.ebuild53
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild70
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild71
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild70
6 files changed, 281 insertions, 0 deletions
diff --git a/mpv-plugin/mpv-mpris/Manifest b/mpv-plugin/mpv-mpris/Manifest
new file mode 100644
index 000000000..4c69ea672
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/Manifest
@@ -0,0 +1,2 @@
+DIST mpv-mpris-0.7.1.tar.gz 13432 BLAKE2B 884204c2186bc3b52378113dde87e58578b3811ec1a40576eb30e779fe3a3575ad9db802a51434e9fc3d22785db6036f898c76acab61780fac4b35276a17524f SHA512 7e928bbbf85b5c8e1e92ce51e65986ef7a7fe27a1e382b0148cdd70e22e5320be37a573c6206b3a1ab05119d9d24b861fd45081a008111f1da37673aa3896f23
+DIST mpv-mpris-0.7.tar.gz 12982 BLAKE2B db919cdad6528519211725694f63871e371a33a331c46eebb202fa87d452d1cf30cecf3d4c2b26cb187cfa2c4cdd53411b88e6e7855510ffbaeef28ab3eb8346 SHA512 b370c9550622302cfdd07c21ae2f03a4e66e80da02e8f38c68d447ef273ae582ad6d918e207a9fb8c917a851163c6aadc08d3d68ad8e70ec85b37732c0cac96f
diff --git a/mpv-plugin/mpv-mpris/metadata.xml b/mpv-plugin/mpv-mpris/metadata.xml
new file mode 100644
index 000000000..b7574b822
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>o.freyermuth@googlemail.com</email>
+ <name>Oliver Freyermuth</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/hoyon/mpv-mpris/issues</bugs-to>
+ <remote-id type="github">hoyon/mpv-mpris</remote-id>
+ </upstream>
+ <use>
+ <flag name="autoload">Load plugin automatically</flag>
+ </use>
+</pkgmetadata>
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1-r1.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1-r1.ebuild
new file mode 100644
index 000000000..ba02bf7f6
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MPV_REQ_USE="cplugins,libmpv"
+inherit mpv-plugin toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-shells/bash
+ app-text/jo
+ media-sound/playerctl
+ net-misc/socat
+ sys-apps/dbus
+ virtual/awk
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+
+MPV_PLUGIN_FILES=( mpris.so )
+
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild
new file mode 100644
index 000000000..2b4e36729
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SLOT="0"
+LICENSE="MIT"
+IUSE="+autoload test"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-video/mpv:=[cplugins,libmpv]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-shells/bash
+ app-text/jo
+ media-sound/playerctl
+ net-misc/socat
+ sys-apps/dbus
+ virtual/awk
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ newlib.so mpris.so ${PN}.so
+ use autoload && dosym -r /usr/$(get_libdir)/${PN}.so /etc/mpv/scripts/mpris.so
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! use autoload; then
+ elog
+ elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
+ elog "You have to activate it manually by passing"
+ elog " '${EPREFIX}/usr/$(get_libdir)/${PN}.so'"
+ elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
+ elog "config directory."
+ elog "Alternatively, activate the autoload use flag."
+ elog
+ fi
+}
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild
new file mode 100644
index 000000000..8814420b5
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SLOT="0"
+LICENSE="MIT"
+IUSE="+autoload test"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-video/mpv:=[cplugins,libmpv]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-shells/bash
+ app-text/jo
+ media-sound/playerctl
+ net-misc/socat
+ sys-apps/dbus
+ virtual/awk
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mpv"
+ doins mpris.so
+ use autoload && dosym -r /usr/$(get_libdir)/mpv/mpris.so /etc/mpv/scripts/mpris.so
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! use autoload; then
+ elog
+ elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
+ elog "You have to activate it manually by passing"
+ elog " '${EPREFIX}/usr/$(get_libdir)/mpv/mpris.so' "
+ elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
+ elog "config directory."
+ elog "Alternatively, activate the autoload use flag."
+ elog
+ fi
+}
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
new file mode 100644
index 000000000..2b4e36729
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SLOT="0"
+LICENSE="MIT"
+IUSE="+autoload test"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-video/mpv:=[cplugins,libmpv]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-shells/bash
+ app-text/jo
+ media-sound/playerctl
+ net-misc/socat
+ sys-apps/dbus
+ virtual/awk
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ newlib.so mpris.so ${PN}.so
+ use autoload && dosym -r /usr/$(get_libdir)/${PN}.so /etc/mpv/scripts/mpris.so
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! use autoload; then
+ elog
+ elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
+ elog "You have to activate it manually by passing"
+ elog " '${EPREFIX}/usr/$(get_libdir)/${PN}.so'"
+ elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
+ elog "config directory."
+ elog "Alternatively, activate the autoload use flag."
+ elog
+ fi
+}