aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-21 14:20:49 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-21 14:33:32 +0100
commitb6fb0f4876e722388cd356c5f5333022f97d31dc (patch)
treefdf0a9db92d4136093ce9eea080b65abfec7c8cc /net-im/nheko
parentdev-cpp/blurhash: new package, add 0.2.0 (diff)
downloadguru-b6fb0f4876e722388cd356c5f5333022f97d31dc.tar.gz
guru-b6fb0f4876e722388cd356c5f5333022f97d31dc.tar.bz2
guru-b6fb0f4876e722388cd356c5f5333022f97d31dc.zip
net-im/nheko: add 0.11.2
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'net-im/nheko')
-rw-r--r--net-im/nheko/Manifest1
-rw-r--r--net-im/nheko/nheko-0.11.2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/net-im/nheko/Manifest b/net-im/nheko/Manifest
index 8e2943df5..59d0e9f20 100644
--- a/net-im/nheko/Manifest
+++ b/net-im/nheko/Manifest
@@ -1,2 +1,3 @@
DIST nheko-0.10.2.tar.gz 1608905 BLAKE2B 10b7b7d1f3e7525ae5ec4b78af228382440c5c64a3716b530506346372856035435d6e2d4e1724f2580ee384852ab0dd4e4b728eed92df827dc5cb3f2853b30b SHA512 b00c45115ab52f9cce5958aa594f6d316bdb917004e284d28ba3003c815bdc532ff1e7bbd5e542bb89a43fd552af3fa44b70ce66eb26b0bcff65beaea1f6b3cd
DIST nheko-0.11.1.tar.gz 1753191 BLAKE2B cbd6c0b7fa8a177ac09b129eae9bfa8c146db8e2d0d289362e20fd35dc1b9245516c2a2b2074fb5e9d2a212dadcf29aac5fd6a3fb910b160906b4dd3caec173e SHA512 3ccaa859ff76a78c024ea2159e666316a3505bc3a3220020a4805ee93351865868b56219ab8421c70ed9922c3f38fbb39370c7f98b702836bd3bb3665c712fda
+DIST nheko-0.11.2.tar.gz 1779259 BLAKE2B 7ae0fd7738cb2b13a657948b0f2f78d079efdd31f7a7799b05f86d6b6e556a0f1c68a441634d4ffa2be2e00e90c1193c71581d910285ec897b061bb1c929ac2b SHA512 ac42065f23c18039e0c40ce5c65615c5dcd7bdc0a92f400ae48e2557380674f60357f2717588f81181149cda29831842c3da904a68b0b00b274dab268522475a
diff --git a/net-im/nheko/nheko-0.11.2.ebuild b/net-im/nheko/nheko-0.11.2.ebuild
new file mode 100644
index 000000000..23609af60
--- /dev/null
+++ b/net-im/nheko/nheko-0.11.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature xdg
+
+DESCRIPTION="Native desktop client for Matrix using Qt"
+HOMEPAGE="https://github.com/Nheko-Reborn/nheko"
+SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X +pie video voip"
+REQUIRED_USE="video? ( voip )"
+
+MY_GST_V="1.18"
+RDEPEND="
+ app-text/cmark:=
+ >=dev-cpp/blurhash-0.2.0:=
+ dev-cpp/cpp-httplib:=
+ dev-cpp/qt-jdenticon
+ dev-db/lmdb:=
+ >=dev-db/lmdb++-1.0.0
+ dev-libs/libfmt:=
+ >=dev-libs/mtxclient-0.9.0:=
+ >=dev-libs/qtkeychain-0.12.0:=
+ >=dev-libs/re2-0.2022.04.01:=
+ dev-libs/spdlog:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5[dbus,jpeg,png]
+ dev-qt/qtimageformats
+ dev-qt/qtmultimedia:5[gstreamer,qml,widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsvg:5
+ virtual/notification-daemon
+ voip? (
+ >=media-plugins/gst-plugins-dtls-${MY_GST_V}
+ media-plugins/gst-plugins-libnice
+ >=media-plugins/gst-plugins-meta-${MY_GST_V}[opus]
+ >=media-plugins/gst-plugins-srtp-${MY_GST_V}
+ >=media-plugins/gst-plugins-webrtc-${MY_GST_V}
+ video? (
+ >=media-libs/gst-plugins-base-${MY_GST_V}[opengl]
+ >=media-plugins/gst-plugins-meta-${MY_GST_V}[v4l,vpx]
+ >=media-plugins/gst-plugins-qt5-${MY_GST_V}
+ X? (
+ >=media-plugins/gst-plugins-ximagesrc-${MY_GST_V}
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ )
+ )
+ )
+"
+DEPEND="
+ dev-cpp/nlohmann_json
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ || (
+ app-text/asciidoc
+ dev-ruby/asciidoctor
+ )
+"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DVOIP=$(usex voip)
+ -DCMAKE_POSITION_INDEPENDENT_CODE=$(usex pie)
+ -DUSE_BUNDLED_CPPHTTPLIB=no
+ -DUSE_BUNDLED_BLURHASH=no
+ )
+ if use video && use X; then
+ mycmakeargs+=(-DSCREENSHARE_X11=yes)
+ else
+ mycmakeargs+=(-DSCREENSHARE_X11=no)
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "audio & video file playback support" \
+ "media-plugins/gst-plugins-meta[ffmpeg]"
+ optfeature "secrets storage support other than kwallet (for example gnome-keyring or keepassxc)" \
+ "dev-libs/qtkeychain[gnome-keyring]"
+ optfeature "additional, less common, image format support" \
+ "kde-frameworks/kimageformats"
+
+ xdg_pkg_postinst
+}