aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-08-10 20:54:15 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-08-10 20:54:15 +0400
commitd62e56e05164932e41d724e218d371d22c7ad679 (patch)
treea342ecfeb98186efad12a2de6386a161554870b0 /net-im/teams-for-linux
parentdev-python/types-protobuf: drop 4.23.0.3 (diff)
downloadguru-d62e56e05164932e41d724e218d371d22c7ad679.tar.gz
guru-d62e56e05164932e41d724e218d371d22c7ad679.tar.bz2
guru-d62e56e05164932e41d724e218d371d22c7ad679.zip
net-im/teams-for-linux: new package, add 1.3.1
Copied from https://gentoo.xwing.info/net-im/teams-for-linux Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'net-im/teams-for-linux')
-rw-r--r--net-im/teams-for-linux/Manifest1
-rw-r--r--net-im/teams-for-linux/files/teams-for-linux.sh19
-rw-r--r--net-im/teams-for-linux/files/teams-for-linux.svg22
-rw-r--r--net-im/teams-for-linux/metadata.xml10
-rw-r--r--net-im/teams-for-linux/teams-for-linux-1.3.1.ebuild44
5 files changed, 96 insertions, 0 deletions
diff --git a/net-im/teams-for-linux/Manifest b/net-im/teams-for-linux/Manifest
new file mode 100644
index 000000000..108ff2b26
--- /dev/null
+++ b/net-im/teams-for-linux/Manifest
@@ -0,0 +1 @@
+DIST teams-for-linux-1.3.1.tar.gz 93146221 BLAKE2B 085d34709ec5069aff1a25dbd6fc9973778b5373cba58e24e2c556f8d49485d9ca76f45a3436f2e299efa156b81780136730fca4d883fa5e6b3a52615c820f65 SHA512 9b64677cb17536e52b1c2cea11dd161953704f69e8bdc7c69c642fc61bf6815081f8efa0c0650cd0ccb210103d5ec28bf1ecab80b3334c29f30b713886d613c3
diff --git a/net-im/teams-for-linux/files/teams-for-linux.sh b/net-im/teams-for-linux/files/teams-for-linux.sh
new file mode 100644
index 000000000..43be26798
--- /dev/null
+++ b/net-im/teams-for-linux/files/teams-for-linux.sh
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+# Allow the user to override command-line flags, bug #357629.
+# This is based on Debian's chromium-browser package, and is intended
+# to be consistent with Debian.
+for f in /etc/chromium/*; do
+ [[ -f ${f} ]] && source "${f}"
+done
+
+# Prefer user defined CHROMIUM_USER_FLAGS (from env) over system
+# default CHROMIUM_FLAGS (from /etc/chromium/default).
+CHROMIUM_FLAGS=${CHROMIUM_USER_FLAGS:-"$CHROMIUM_FLAGS"}
+
+# Let the wrapped binary know that it has been run through the wrapper.
+export CHROME_WRAPPER="$(readlink -f "$0")"
+
+HERE="$(dirname "$CHROME_WRAPPER")"
+
+exec -a "teams-for-linux" "$HERE/teams-for-linux" ${CHROMIUM_FLAGS} "$@"
diff --git a/net-im/teams-for-linux/files/teams-for-linux.svg b/net-im/teams-for-linux/files/teams-for-linux.svg
new file mode 100644
index 000000000..34be9847d
--- /dev/null
+++ b/net-im/teams-for-linux/files/teams-for-linux.svg
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 2228.833 2073.333">
+ <path fill="#5059C9" d="M1554.637,777.5h575.713c54.391,0,98.483,44.092,98.483,98.483c0,0,0,0,0,0v524.398 c0,199.901-162.051,361.952-361.952,361.952h0h-1.711c-199.901,0.028-361.975-162-362.004-361.901c0-0.017,0-0.034,0-0.052V828.971 C1503.167,800.544,1526.211,777.5,1554.637,777.5L1554.637,777.5z"/>
+ <circle fill="#5059C9" cx="1943.75" cy="440.583" r="233.25"/>
+ <circle fill="#7B83EB" cx="1218.083" cy="336.917" r="336.917"/>
+ <path fill="#7B83EB" d="M1667.323,777.5H717.01c-53.743,1.33-96.257,45.931-95.01,99.676v598.105 c-7.505,322.519,247.657,590.16,570.167,598.053c322.51-7.893,577.671-275.534,570.167-598.053V877.176 C1763.579,823.431,1721.066,778.83,1667.323,777.5z"/>
+ <path opacity=".1" d="M1244,777.5v838.145c-0.258,38.435-23.549,72.964-59.09,87.598 c-11.316,4.787-23.478,7.254-35.765,7.257H667.613c-6.738-17.105-12.958-34.21-18.142-51.833 c-18.144-59.477-27.402-121.307-27.472-183.49V877.02c-1.246-53.659,41.198-98.19,94.855-99.52H1244z"/>
+ <path opacity=".2" d="M1192.167,777.5v889.978c-0.002,12.287-2.47,24.449-7.257,35.765 c-14.634,35.541-49.163,58.833-87.598,59.09H691.975c-8.812-17.105-17.105-34.21-24.362-51.833 c-7.257-17.623-12.958-34.21-18.142-51.833c-18.144-59.476-27.402-121.307-27.472-183.49V877.02 c-1.246-53.659,41.198-98.19,94.855-99.52H1192.167z"/>
+ <path opacity=".2" d="M1192.167,777.5v786.312c-0.395,52.223-42.632,94.46-94.855,94.855h-447.84 c-18.144-59.476-27.402-121.307-27.472-183.49V877.02c-1.246-53.659,41.198-98.19,94.855-99.52H1192.167z"/>
+ <path opacity=".2" d="M1140.333,777.5v786.312c-0.395,52.223-42.632,94.46-94.855,94.855H649.472 c-18.144-59.476-27.402-121.307-27.472-183.49V877.02c-1.246-53.659,41.198-98.19,94.855-99.52H1140.333z"/>
+ <path opacity=".1" d="M1244,509.522v163.275c-8.812,0.518-17.105,1.037-25.917,1.037 c-8.812,0-17.105-0.518-25.917-1.037c-17.496-1.161-34.848-3.937-51.833-8.293c-104.963-24.857-191.679-98.469-233.25-198.003 c-7.153-16.715-12.706-34.071-16.587-51.833h258.648C1201.449,414.866,1243.801,457.217,1244,509.522z"/>
+ <path opacity=".2" d="M1192.167,561.355v111.442c-17.496-1.161-34.848-3.937-51.833-8.293 c-104.963-24.857-191.679-98.469-233.25-198.003h190.228C1149.616,466.699,1191.968,509.051,1192.167,561.355z"/>
+ <path opacity=".2" d="M1192.167,561.355v111.442c-17.496-1.161-34.848-3.937-51.833-8.293 c-104.963-24.857-191.679-98.469-233.25-198.003h190.228C1149.616,466.699,1191.968,509.051,1192.167,561.355z"/>
+ <path opacity=".2" d="M1140.333,561.355v103.148c-104.963-24.857-191.679-98.469-233.25-198.003 h138.395C1097.783,466.699,1140.134,509.051,1140.333,561.355z"/>
+ <linearGradient id="a" gradientUnits="userSpaceOnUse" x1="198.099" y1="1683.0726" x2="942.2344" y2="394.2607" gradientTransform="matrix(1 0 0 -1 0 2075.3333)">
+ <stop offset="0" stop-color="#5a62c3"/>
+ <stop offset=".5" stop-color="#4d55bd"/>
+ <stop offset="1" stop-color="#3940ab"/>
+ </linearGradient>
+ <path fill="url(#a)" d="M95.01,466.5h950.312c52.473,0,95.01,42.538,95.01,95.01v950.312c0,52.473-42.538,95.01-95.01,95.01 H95.01c-52.473,0-95.01-42.538-95.01-95.01V561.51C0,509.038,42.538,466.5,95.01,466.5z"/>
+ <path fill="#FFF" d="M820.211,828.193H630.241v517.297H509.211V828.193H320.123V727.844h500.088V828.193z"/>
+</svg> \ No newline at end of file
diff --git a/net-im/teams-for-linux/metadata.xml b/net-im/teams-for-linux/metadata.xml
new file mode 100644
index 000000000..61ff0c408
--- /dev/null
+++ b/net-im/teams-for-linux/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>casta@xwing.info</email>
+ <name>Guillaume Castagnino</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">IsmaelMartinez/teams-for-linux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/teams-for-linux/teams-for-linux-1.3.1.ebuild b/net-im/teams-for-linux/teams-for-linux-1.3.1.ebuild
new file mode 100644
index 000000000..404249af9
--- /dev/null
+++ b/net-im/teams-for-linux/teams-for-linux-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg multilib-build
+
+DESCRIPTION="Microsoft Teams client for Linux. Binary precompiled version."
+HOMEPAGE="https://teams.microsoft.com/ https://github.com/IsmaelMartinez/teams-for-linux"
+SRC_URI="https://github.com/IsmaelMartinez/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE=""
+DEPEND=">=app-accessibility/at-spi2-core-2.46.0:2[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-gfx/graphite2[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+
+src_install() {
+ dodir /opt/${PN}
+ cp -a . "${ED}"/opt/${PN} || die
+
+ # install wrapper reading /etc/chromium/* for CHROME_FLAGS
+ exeinto /opt/${PN}
+ doexe "${FILESDIR}/${PN}.sh"
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/${PN}/chrome-sandbox || die
+
+ dosym ../../opt/${PN}/${PN}.sh /usr/bin/${PN}
+
+ newicon -s scalable "${FILESDIR}/${PN}.svg" ${PN}.svg
+ make_desktop_entry "${EPREFIX}"/opt/${PN}/${PN}.sh "Teams for Linux" \
+ ${PN} "Network;Chat;InstantMessaging;" \
+ "MimeType=x-scheme-handler/msteams;"
+}