aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-03-23 08:41:50 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-03-23 08:41:50 +0200
commit6c80a32cb4acec3b68e3d6b06d0dee12bbe2d4a8 (patch)
tree6c176dde4a860f46e00a72a108b6c23625c86677 /net-misc
parentnet-misc/maestral: add 1.9.1, drop 1.8.1_rc0 (diff)
downloadguru-6c80a32cb4acec3b68e3d6b06d0dee12bbe2d4a8.tar.gz
guru-6c80a32cb4acec3b68e3d6b06d0dee12bbe2d4a8.tar.bz2
guru-6c80a32cb4acec3b68e3d6b06d0dee12bbe2d4a8.zip
net-misc/maestral-qt: add 1.9.1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/maestral-qt/Manifest1
-rw-r--r--net-misc/maestral-qt/maestral-qt-1.9.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/maestral-qt/Manifest b/net-misc/maestral-qt/Manifest
index 4b32b370c..af1d30a01 100644
--- a/net-misc/maestral-qt/Manifest
+++ b/net-misc/maestral-qt/Manifest
@@ -1 +1,2 @@
DIST maestral-qt-1.8.0.gh.tar.gz 1219570 BLAKE2B 83c3d67b169f04553f3885e3ae008fe04284bb9fd9a7b2888e2146e298e85cc15f639d83359165a957f8832bb34d3bf129ddd850d58b6e808e257d5784a2e1b4 SHA512 2cf19185fce01b5d1884215522987ba77484e6d6cb9a3745503fd2bc66c796db839ee7dc863fb3b8e3b55b95af013bf23b00bc60cb7106d265766ca813482bdd
+DIST maestral-qt-1.9.1.gh.tar.gz 1219592 BLAKE2B 31ac7bf91499c46ae0cbab508e7c9e9591c0a0f766b6de00f2d4f19f3d0ebb6c513c4f2785c0b31210f7401ae59b98eaa7b753676953206e4a295d2783950ed4 SHA512 ff1ade8625655be61b0c10ad5a66c1d53984852cb9346d6ca552bb3783f451fae46a2277598d2d8c9cd3e96db0fbdef1dc38f23c2e6c99806b634a73b8589ba5
diff --git a/net-misc/maestral-qt/maestral-qt-1.9.1.ebuild b/net-misc/maestral-qt/maestral-qt-1.9.1.ebuild
new file mode 100644
index 000000000..c15493aa2
--- /dev/null
+++ b/net-misc/maestral-qt/maestral-qt-1.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit desktop distutils-r1
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/PyQt6[widgets,gui,svg,${PYTHON_USEDEP}]
+ >=net-misc/maestral-${PV%_rc*}_rc0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ domenu src/maestral_qt/resources/maestral.desktop
+}