aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Henke <Jan.Henke@taujhe.de>2024-06-08 20:43:45 +0200
committerJan Henke <Jan.Henke@taujhe.de>2024-06-08 20:43:45 +0200
commit80c0936cbadd90f7ec2b01fe0581dd27e8d4f749 (patch)
treedf93089f5f06f8fa2ecd3f47045344410e677ee6 /sci-electronics
parentsci-electronics/liblxi: drop 1.16, 1.18 (diff)
downloadguru-80c0936cbadd90f7ec2b01fe0581dd27e8d4f749.tar.gz
guru-80c0936cbadd90f7ec2b01fe0581dd27e8d4f749.tar.bz2
guru-80c0936cbadd90f7ec2b01fe0581dd27e8d4f749.zip
sci-electronics/lxi-tools: add 2.7
Closes: https://bugs.gentoo.org/931474 Signed-off-by: Jan Henke <Jan.Henke@taujhe.de>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/lxi-tools/Manifest1
-rw-r--r--sci-electronics/lxi-tools/lxi-tools-2.7.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-electronics/lxi-tools/Manifest b/sci-electronics/lxi-tools/Manifest
index a0c21dc0c..002c827a7 100644
--- a/sci-electronics/lxi-tools/Manifest
+++ b/sci-electronics/lxi-tools/Manifest
@@ -1,2 +1,3 @@
DIST lxi-tools-2.1.tar.gz 937946 BLAKE2B 25de9b879bd5db4e664aa2420598b22838477f10485247d6f435249dbc7c3d866c439362a99252c7fee329b7cf2a24c2bd72f523aac55a5cb70db914031daf0c SHA512 ddf54826aa3f50a575d2c5f6e62d6a1a813adde275530b19c4e7465e689f43fea290aab4c5762498e2437e67bade577ace4f12cd24ae41c99f811772c38ad307
DIST lxi-tools-2.3.tar.gz 1001920 BLAKE2B 5fa8d24403e98366436270fba543dd3086f34a194c3995ce0b628b7ec1605d1319b4468b371d08ea88db1fd653311108d03b43a49533060472e6b1495072442a SHA512 3bf885d0d9b96b525809cd3fb5fbedb1ffc2728f523a31cc1bb8c45657d9e4eec7d954e085f752b89a3016cc01f021c773ddbd1d876a4af8a7b72719275dc4c7
+DIST lxi-tools-2.7.tar.gz 1007967 BLAKE2B d29da7d1be3ba2809a390ab501077f7711a3fa9d1d93eb67fb43c302841bbdcc0c3cf64aa90e6d0789aabf714c6d7ea204ec8318861d69317d80118c16127df2 SHA512 de295f4ba04e5c119929c413112373faa6b019b48e4afee47001cbe145ed3e5dbf30700ce219af9deec0d6a68b169fe7493c65569b99ca1324a0cffcc7463f0d
diff --git a/sci-electronics/lxi-tools/lxi-tools-2.7.ebuild b/sci-electronics/lxi-tools/lxi-tools-2.7.ebuild
new file mode 100644
index 000000000..682708e0b
--- /dev/null
+++ b/sci-electronics/lxi-tools/lxi-tools-2.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python{3_12,3_13} )
+LUA_COMPAT=( lua5-{1..4} )
+inherit meson python-any-r1 lua-single gnome2-utils xdg-utils
+
+DESCRIPTION="Tools to access devices with LXI"
+HOMEPAGE="https://github.com/lxi-tools/lxi-tools"
+SRC_URI="https://github.com/lxi-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bash-completion +gui"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ bash-completion? ( >=app-shells/bash-completion-2.11 )
+ >=sys-libs/readline-8.1_p2
+ ${LUA_DEPS}
+ >=sci-electronics/liblxi-1.13
+ gui? (
+ >=dev-libs/glib-2.70
+ >=gui-libs/gtk-4.6.0
+ >=gui-libs/gtksourceview-5.4.0
+ >=gui-libs/libadwaita-1.2
+ >=dev-libs/json-glib-1.4
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ # fix lua dependency string in meson-build
+ sed -i 's/lua-/lua/g' ${S}/src/meson.build || die
+
+ local emesonargs=(
+ $(meson_use gui)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}