aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-29 04:16:54 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-29 04:16:54 +0200
commit10c148017d2151ec330e1959fe71f3e6e9aaebc1 (patch)
treee2a8e0e3bdc58d3f0c3af98c6192190b38b89e7c /sci-mathematics
parentsci-mathematics/packup: swap {R,}DEPEND logic (diff)
downloadguru-10c148017d2151ec330e1959fe71f3e6e9aaebc1.tar.gz
guru-10c148017d2151ec330e1959fe71f3e6e9aaebc1.tar.bz2
guru-10c148017d2151ec330e1959fe71f3e6e9aaebc1.zip
sci-mathematics/radian: add 0.6.1
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/radian/Manifest1
-rw-r--r--sci-mathematics/radian/radian-0.6.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/radian/Manifest b/sci-mathematics/radian/Manifest
index 5f5ef5dae..f829dda2f 100644
--- a/sci-mathematics/radian/Manifest
+++ b/sci-mathematics/radian/Manifest
@@ -1 +1,2 @@
DIST radian-0.6.0-github.tar.gz 73474 BLAKE2B 5691848c9e13ef8e3b55692e8270f2a189a067aeaf658ef4e5252ad1855bd4fb9224e26db512f51151887bcb58747732a88e48d74f77d1af61e08666effe90b1 SHA512 dcd2183248b62bda728ff6dfc5e15bd80d6d21c8f0fd3a4f976c4e6149b306b6c70af8de6aa202386b97734d6b7b309667314677d183899b469debce098fb532
+DIST radian-0.6.1-github.tar.gz 73582 BLAKE2B c0b091782dde617abbba1ca8363c4b30a4649a5dbb712a40e9cee7be6b6775a9d952b18db9522827b6b0d8ddc0b3fe6d5003b703d9cdc19b2a763e76c4c81b79 SHA512 e768219e8f850062f2e6327d12ce7d61ed00eb74626ab224a6b33ef5963d44067e3cf99f955f42d0eaad48eb11e42c6743fb9a95361ebc014216527c8939c862
diff --git a/sci-mathematics/radian/radian-0.6.1.ebuild b/sci-mathematics/radian/radian-0.6.1.ebuild
new file mode 100644
index 000000000..76558d841
--- /dev/null
+++ b/sci-mathematics/radian/radian-0.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A 21 century R console"
+HOMEPAGE="
+ https://pypi.org/project/radian/
+ https://github.com/randy3k/radian
+"
+SRC_URI="https://github.com/randy3k/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}-github.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/rchitect-0.3.36[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-3.0.15[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.5.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ dev-lang/R
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/pyte-0.8.0[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ ')
+ dev-R/reticulate[${PYTHON_SINGLE_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-pytest-runner.patch" )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "prompt completions" dev-python/jedi
+}