aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-25 14:11:24 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-25 14:17:52 +0200
commitdd952e12e2347c07325a46c535463a29c03fdf5b (patch)
tree5f05c60abae9276b4de7a0c395b90b42d2f4fb69 /sys-cluster
parentdev-python/osprofiler: ignore deprecated jaeger tests (diff)
downloadguru-dd952e12e2347c07325a46c535463a29c03fdf5b.tar.gz
guru-dd952e12e2347c07325a46c535463a29c03fdf5b.tar.bz2
guru-dd952e12e2347c07325a46c535463a29c03fdf5b.zip
sys-cluster/Graph500: conditional chrpath
Closes: https://bugs.gentoo.org/847340 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/Graph500/Graph500-1.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-cluster/Graph500/Graph500-1.2.ebuild b/sys-cluster/Graph500/Graph500-1.2.ebuild
index dae92c7d6..36601d979 100644
--- a/sys-cluster/Graph500/Graph500-1.2.ebuild
+++ b/sys-cluster/Graph500/Graph500-1.2.ebuild
@@ -51,7 +51,10 @@ src_install() {
doins *.html
insinto "/usr/share/octave/site/m/${PN}"
doins -r octave/*
- chrpath -d "${ED}/usr/bin/graph500_mpi_one_sided" || die
- chrpath -d "${ED}/usr/bin/graph500_mpi_simple" || die
- chrpath -d "${ED}/usr/bin/generator_test_mpi" || die
+
+ if use mpi ; then
+ chrpath -d "${ED}/usr/bin/graph500_mpi_one_sided" || die
+ chrpath -d "${ED}/usr/bin/graph500_mpi_simple" || die
+ chrpath -d "${ED}/usr/bin/generator_test_mpi" || die
+ fi
}