aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-08-05 12:41:30 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-08-05 12:55:49 +0200
commit480d181c6b72854f04bd83db94e73029044b3771 (patch)
tree718ddb6d92e8e915dfd0c9c1fbb0a4590134fe8f /sys-fs
parentsys-fs/sanoid: remove local USE flag description (diff)
downloadguru-480d181c6b72854f04bd83db94e73029044b3771.tar.gz
guru-480d181c6b72854f04bd83db94e73029044b3771.tar.bz2
guru-480d181c6b72854f04bd83db94e73029044b3771.zip
sys-fs/sanoid: move configuration tooltip to pkg_postinst
fixes VariableScopeCheck for REPLACING_VERSIONS Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/sanoid/sanoid-2.2.0.ebuild12
-rw-r--r--sys-fs/sanoid/sanoid-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/sys-fs/sanoid/sanoid-2.2.0.ebuild b/sys-fs/sanoid/sanoid-2.2.0.ebuild
index 1e676fb4ed..515b82ac71 100644
--- a/sys-fs/sanoid/sanoid-2.2.0.ebuild
+++ b/sys-fs/sanoid/sanoid-2.2.0.ebuild
@@ -48,16 +48,16 @@ src_install() {
insinto /etc/sanoid
doins "sanoid.defaults.conf"
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "You will need to set up your /etc/sanoid/sanoid.conf file before"
- elog "running sanoid for the first time. For details, please consult the"
- elog "documentation on https://github.com/jimsalterjrs/sanoid."
- fi
}
pkg_postinst() {
optfeature "lzop compression support" app-arch/lzop
optfeature "pigz compression support" app-arch/pigz
optfeature "zstd compression support" app-arch/zstd
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to set up your ${EROOT}/etc/sanoid/sanoid.conf file before"
+ elog "running sanoid for the first time. For details, please consult the"
+ elog "documentation on https://github.com/jimsalterjrs/sanoid."
+ fi
}
diff --git a/sys-fs/sanoid/sanoid-9999.ebuild b/sys-fs/sanoid/sanoid-9999.ebuild
index 1e676fb4ed..515b82ac71 100644
--- a/sys-fs/sanoid/sanoid-9999.ebuild
+++ b/sys-fs/sanoid/sanoid-9999.ebuild
@@ -48,16 +48,16 @@ src_install() {
insinto /etc/sanoid
doins "sanoid.defaults.conf"
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "You will need to set up your /etc/sanoid/sanoid.conf file before"
- elog "running sanoid for the first time. For details, please consult the"
- elog "documentation on https://github.com/jimsalterjrs/sanoid."
- fi
}
pkg_postinst() {
optfeature "lzop compression support" app-arch/lzop
optfeature "pigz compression support" app-arch/pigz
optfeature "zstd compression support" app-arch/zstd
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to set up your ${EROOT}/etc/sanoid/sanoid.conf file before"
+ elog "running sanoid for the first time. For details, please consult the"
+ elog "documentation on https://github.com/jimsalterjrs/sanoid."
+ fi
}