aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2024-07-02 18:09:58 +0500
committerDenis Reva <denis7774@gmail.com>2024-07-02 23:12:21 +0500
commit580798130fab3292ae9eb110fa239bca33269bd3 (patch)
tree4be638cfa3a75d0c1ba5c352090fc6545964f674 /sys-fs
parentdev-libs/libtypec-utils: move from dev-libs to dev-util (diff)
downloadguru-580798130fab3292ae9eb110fa239bca33269bd3.tar.gz
guru-580798130fab3292ae9eb110fa239bca33269bd3.tar.bz2
guru-580798130fab3292ae9eb110fa239bca33269bd3.zip
sys-fs/dwarfs: drop 0.9.9
Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dwarfs/Manifest1
-rw-r--r--sys-fs/dwarfs/dwarfs-0.9.9.ebuild137
2 files changed, 0 insertions, 138 deletions
diff --git a/sys-fs/dwarfs/Manifest b/sys-fs/dwarfs/Manifest
index 2c3f9d401..f534590c3 100644
--- a/sys-fs/dwarfs/Manifest
+++ b/sys-fs/dwarfs/Manifest
@@ -1,2 +1 @@
DIST dwarfs-0.9.10.tar.xz 18618308 BLAKE2B be992c645b76c277e08c5ccaa80665c7303a8a218ead430b2f382b1f537d42debd095c94697dfff24246985d70efb70aeae8d4f4e68f3461bc0dca3f6135a184 SHA512 c67ac3586a7f36e4439a1c63b292ad1f1c61e6bc307b9711785a97d7146c686bc3918ff031188bfaa741829114a661e80bb7e4b5d7ce4f4b3f6d1e86e8532ec9
-DIST dwarfs-0.9.9.tar.xz 18614744 BLAKE2B c8f98b737d86444a6a074f7de2704edb94c86bd80e4024d021d4887240f9e1a5b52187ca2e82257427b2392d4afc7c7081985d5b5cc5d8b593f7221c4bc12126 SHA512 7f7f2d49f25856b6e88cf8bda0f194efeeac88eab9f0b9079d02fa871af2b8181879ece7170e36653b75246b421e6a1c54c04a5156b4e1803a0a202472232da0
diff --git a/sys-fs/dwarfs/dwarfs-0.9.9.ebuild b/sys-fs/dwarfs/dwarfs-0.9.9.ebuild
deleted file mode 100644
index 42bdd10ad..000000000
--- a/sys-fs/dwarfs/dwarfs-0.9.9.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit check-reqs cmake flag-o-matic python-any-r1
-
-DESCRIPTION="A fast very high compression read-only FUSE file system"
-HOMEPAGE="https://github.com/mhx/dwarfs"
-SRC_URI="https://github.com/mhx/dwarfs/releases/download/v${PV}/${P}.tar.xz"
-
-S="${WORKDIR}/dwarfs-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+jemalloc test man" #Tests is broken at this moment
-# See https://github.com/mhx/dwarfs/issues/194
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/brotli
- app-arch/libarchive
- app-arch/lz4
- app-arch/snappy
- app-arch/xz-utils
- app-arch/zstd
- dev-cpp/range-v3
- dev-cpp/gflags
- dev-cpp/glog[gflags]
- dev-cpp/parallel-hashmap:=
- dev-libs/boost[context]
- dev-libs/date
- dev-libs/double-conversion
- dev-libs/libevent
- dev-libs/libfmt
- dev-libs/utfcpp
- dev-libs/xxhash
- dev-libs/fsst
- media-libs/flac
- sys-fs/fuse:3
- sys-libs/binutils-libs
- sys-libs/zlib
- jemalloc? ( >=dev-libs/jemalloc-5.3.0-r1 )
-"
-
-DEPEND="${RDEPEND}
- sys-libs/libunwind"
-BDEPEND="
- ${PYTHON_DEPS}
- dev-util/patchelf
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
- man? ( app-text/ronn-ng )
- test? ( dev-cpp/gtest )
- $(python_gen_any_dep 'dev-python/mistletoe[${PYTHON_USEDEP}]')
-"
-
-DOCS=( "README.md" "CHANGES.md" "TODO" )
-
-CHECKREQS_DISK_BUILD="1300M"
-CMAKE_IN_SOURCE_BUILD=1
-CMAKE_WARN_UNUSED_CLI=0
-
-python_check_deps() {
- python_has_version -b "dev-python/mistletoe[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- rm -r zstd xxHash parallel-hashmap || die
- sed "s/DESTINATION lib/DESTINATION $(get_libdir)/" -i CMakeLists.txt || die
-
- # Bug #900016, but upstream discourages O3
- sed '/FLAGS_RELEASE/s# -O2 -g##' -i CMakeLists.txt || die
- sed '/CMAKE_CXX_FLAGS_COMMON/s#-g ##' -i folly/CMake/FollyCompilerUnix.cmake || die
- sed '/^\s*-g$/d' -i folly/CMake/FollyCompilerUnix.cmake || die
- replace-flags -O3 -O2
- # Fixes building with test when using system-gtest
- # https://github.com/mhx/dwarfs/issues/188
- sed '/utils_test/d' -i CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- append-cxxflags "-I/usr/include"
- filter-ldflags "-Wl,--as-needed"
- append-ldflags $(no-as-needed)
-
- # FIXME: Requires dev-cpp/gtest to be built with -fchar8_t or -std=c++20.
- # This is unfortunately too aggressive:
- # append-cxxflags "-fno-char8_t"
-
- mycmakeargs=(
- -DUSE_JEMALLOC=$(usex jemalloc ON OFF)
- -DWITH_TESTS=$(usex test ON OFF)
- -DWITH_MAN_PAGES=$(usex man ON OFF)
- -DPREFER_SYSTEM_ZSTD=ON
- -DPREFER_SYSTEM_XXHASH=ON
- -DPREFER_SYSTEM_GTEST=ON
- -DPREFER_SYSTEM_LIBFMT=ON
- -DWITH_LEGACY_FUSE=OFF
- -DDISABLE_CCACHE=ON # Use FEATURES=ccache
- -DBUILD_SHARED_LIBS=OFF # It can be very difficult to explain
- # Shared libs is not fully supported by upstream
- # https://github.com/mhx/dwarfs/issues/184#issuecomment-1873820859
- # So if we disable shared libs we dramatically reduce install code and
- # remove libs collision with dev-cpp/folly, dev-cpp/fbthrift,
- # dev-cpp/fizz, and dev-cpp/wangle
- # We do NOT enable the full static build, but eradicate bundled libs
- # such as libfolly.so and libdwarfs_compression.so
- -DCMAKE_FIND_LIBRARY_SUFFIXES=".a"
- )
- cmake_src_configure
-}
-
-src_test() {
- local CMAKE_SKIP_TESTS=(
- # Tests don't work in sandbox
- # fuse: failed to open /dev/fuse: Permission denied
- dwarfs/tools_test
- # Some tests doesn't work because of sed '/utils_test/d'
- dwarfsextract_test.perfmon
- dwarfs/segmenter_repeating_sequence_test.github161
- )
- cmake_src_test
-}
-
-pkg_postinst() {
- elog "You may find more information in the"
- elog "${HOMEPAGE}"
- elog "About creating: ${HOMEPAGE}/blob/main/doc/mkdwarfs.md"
- elog "About mounting: ${HOMEPAGE}/blob/main/doc/dwarfs.md"
-}