aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-07-05 18:18:00 +0100
committerAlexey Sokolov <alexey+gentoo@asokolov.org>2024-07-05 18:37:32 +0100
commit83c9c1613fe6713cc18a81a6095953735066f6ad (patch)
treefdf3d2eddfe5b31805d53eb70f79688b5fbc8653 /sys-fs
parentdev-libs/libchardet: new package, add 1.0.6 (diff)
downloadguru-83c9c1613fe6713cc18a81a6095953735066f6ad.tar.gz
guru-83c9c1613fe6713cc18a81a6095953735066f6ad.tar.bz2
guru-83c9c1613fe6713cc18a81a6095953735066f6ad.zip
sys-fs/ffmpegfs: new package, add 2.16
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ffmpegfs/Manifest1
-rw-r--r--sys-fs/ffmpegfs/ffmpegfs-2.16.ebuild49
-rw-r--r--sys-fs/ffmpegfs/files/ffmpegfs-2.16-cflags.patch24
-rw-r--r--sys-fs/ffmpegfs/files/ffmpegfs-2.16-varcache.patch12
-rw-r--r--sys-fs/ffmpegfs/metadata.xml20
5 files changed, 106 insertions, 0 deletions
diff --git a/sys-fs/ffmpegfs/Manifest b/sys-fs/ffmpegfs/Manifest
new file mode 100644
index 000000000..e9a6afa5e
--- /dev/null
+++ b/sys-fs/ffmpegfs/Manifest
@@ -0,0 +1 @@
+DIST ffmpegfs-2.16.tar.gz 14630485 BLAKE2B 69fcf7b9020b2a3b38a8719d9fd6766963ec0f642567c3b852a92408531988295c4e71557bd16f520660078fd314f170a934d6bb700321f9d90bff108209ca30 SHA512 9e3f3a8fc186c19b73edfa98f88a64d5536a1b8ade47f07c4e053a0e002aa729968efb67d92f4086476f55d72c67c4037e7c0965a672c4638be07afc3ed6a9a5
diff --git a/sys-fs/ffmpegfs/ffmpegfs-2.16.ebuild b/sys-fs/ffmpegfs/ffmpegfs-2.16.ebuild
new file mode 100644
index 000000000..4b681adab
--- /dev/null
+++ b/sys-fs/ffmpegfs/ffmpegfs-2.16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="FUSE-based transcoding filesystem with support from/to many formats."
+HOMEPAGE="https://nschlia.github.io/ffmpegfs/"
+SRC_URI="https://github.com/nschlia/ffmpegfs/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bluray dvd"
+
+RESTRICT="test" # needs /dev/fuse
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ www-client/w3m
+"
+DEPEND="
+ dev-db/sqlite:3
+ dev-libs/libchardet
+ media-libs/libcue:=
+ media-video/ffmpeg:=
+ sys-fs/fuse
+ bluray? ( media-libs/libbluray:= )
+ dvd? ( media-libs/libdvdread:= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/ffmpegfs-2.16-cflags.patch"
+ "${FILESDIR}/ffmpegfs-2.16-varcache.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with bluray libbluray) \
+ $(use_with dvd libdvd)
+}
diff --git a/sys-fs/ffmpegfs/files/ffmpegfs-2.16-cflags.patch b/sys-fs/ffmpegfs/files/ffmpegfs-2.16-cflags.patch
new file mode 100644
index 000000000..2bc78e218
--- /dev/null
+++ b/sys-fs/ffmpegfs/files/ffmpegfs-2.16-cflags.patch
@@ -0,0 +1,24 @@
+Respect user's CFLAGS
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,7 @@
+ if DEBUG
+ export OPTIMISATION = -DDEBUG -ggdb -fstack-protector-explicit
+ else
+-export OPTIMISATION = -DNDEBUG -Ofast -g
++export OPTIMISATION = -DNDEBUG
+ endif
+
+ export WARNINGS = -Wall -Wextra -Wconversion -Wsign-compare -Wsign-conversion -Wpedantic
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,8 +19,6 @@ AC_CANONICAL_HOST
+ AC_DEFINE_UNQUOTED([HOST_OS], ["$host_os"], [Host operating system])
+
+ # compiler flags
+-CFLAGS=""
+-CXXFLAGS=""
+
+ # Checks for programs
+ AC_PROG_CC
diff --git a/sys-fs/ffmpegfs/files/ffmpegfs-2.16-varcache.patch b/sys-fs/ffmpegfs/files/ffmpegfs-2.16-varcache.patch
new file mode 100644
index 000000000..20a96195d
--- /dev/null
+++ b/sys-fs/ffmpegfs/files/ffmpegfs-2.16-varcache.patch
@@ -0,0 +1,12 @@
+Don't install to /var/cache
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -156,7 +156,6 @@ install-exec-hook:
+ echo "$(CACHEDIR) already exists."; \
+ else \
+ echo "Creating cache in $(CACHEDIR)."; \
+- mkdir -p $(CACHEDIR) || true; \
+ fi
+
+ uninstall-hook:
diff --git a/sys-fs/ffmpegfs/metadata.xml b/sys-fs/ffmpegfs/metadata.xml
new file mode 100644
index 000000000..41c1887db
--- /dev/null
+++ b/sys-fs/ffmpegfs/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <use>
+ <flag name="bluray">Enable support of Blu-ray</flag>
+ </use>
+ <longdescription lang="en">
+ FFmpegfs is a read-only FUSE filesystem which transcodes various audio and video formats to MP4, WebM, and many more on the fly when opened and read using the FFmpeg library, thus supporting a multitude of input formats and a variety of common output formats.
+
+ This allows access to a multi-media file collection with software and/or hardware which only understands one of the supported output formats, or transcodes files through simple drag-and-drop in a file browser.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/nschlia/ffmpegfs/issues</bugs-to>
+ <remote-id type="github">nschlia/ffmpegfs</remote-id>
+ </upstream>
+</pkgmetadata>