aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-05-20 17:59:17 -0500
committerZen <z@pyl.onl>2024-05-20 17:59:17 -0500
commit8c04ba9740d500227c14c3cd3c63c3f7a59766b5 (patch)
tree167bfe0a69417386add42b2f831142899020361a /sys-kernel
parentsys-kernel/ugrd: Add 1.7.0 (diff)
downloadguru-8c04ba9740d500227c14c3cd3c63c3f7a59766b5.tar.gz
guru-8c04ba9740d500227c14c3cd3c63c3f7a59766b5.tar.bz2
guru-8c04ba9740d500227c14c3cd3c63c3f7a59766b5.zip
sys-kernel/ugrd: Add 9999 ebuild
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/ugrd-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/ugrd-9999.ebuild b/sys-kernel/ugrd/ugrd-9999.ebuild
new file mode 100644
index 000000000..fe1d076ec
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature shell-completion git-r3
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+EGIT_REPO_URI="https://github.com/desultory/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ app-misc/pax-utils
+ >=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pycpio-1.1.2[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ keepdir /etc/kernel/preinst.d
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/installkernel/51-ugrd.install
+ exeinto /lib/kernel/install.d
+ doexe hooks/kernel-install/51-ugrd.install
+ # Install bash autocomplete script
+ dobashcomp completion/ugrd
+ dozshcomp completion/_ugrd
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+}