aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-09 03:04:28 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-10 02:05:46 +0100
commit2a43e32d293444b43a88168d8a8b1a682c258526 (patch)
treedd476f80dcc18fafd28742063ab6d625fec16541 /sys-libs
parentapp-misc/zellij: improve ebuild and take it (diff)
downloadguru-2a43e32d293444b43a88168d8a8b1a682c258526.tar.gz
guru-2a43e32d293444b43a88168d8a8b1a682c258526.tar.bz2
guru-2a43e32d293444b43a88168d8a8b1a682c258526.zip
sys-libs/safeclib: fix stdarg.h not found
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/safeclib/Manifest1
-rw-r--r--sys-libs/safeclib/files/gh96.patch11
-rw-r--r--sys-libs/safeclib/files/safeclib-3.7.1-stdarg.patch11
-rw-r--r--sys-libs/safeclib/safeclib-3.6.0_p20210407-r2.ebuild106
-rw-r--r--sys-libs/safeclib/safeclib-3.6.0_p20210407-r3.ebuild108
-rw-r--r--sys-libs/safeclib/safeclib-3.7.1-r1.ebuild (renamed from sys-libs/safeclib/safeclib-3.7.1.ebuild)6
6 files changed, 15 insertions, 228 deletions
diff --git a/sys-libs/safeclib/Manifest b/sys-libs/safeclib/Manifest
index 6dbb2767a..e87d7e189 100644
--- a/sys-libs/safeclib/Manifest
+++ b/sys-libs/safeclib/Manifest
@@ -1,2 +1 @@
-DIST safeclib-3.6.0_p20210407.tar.gz 2281868 BLAKE2B 1690f4ac7504cdd37cd353cd0ddab8d9807a583113a5893fd0633c69b7434c3eecf361ae501570819bb8d75a057c0c861f6c594429162558c73330bcd2c04df5 SHA512 2e21a06b4a423ea7a7782b101ba9f0e8a60efaaec49314360014ebae02d0a02a4275ccecc618560b08dc357b9fbb4c5b220db70012728dbb3815635e8dad16c8
DIST safeclib-3.7.1.tar.xz 539072 BLAKE2B 55e828f2c195325a9a3648f57d1e60a6657289ff03ebe626d5884f41014d747591fd2240286d4060ffc58c368e68464bed49eb34a5d78cdd1e204861ca8425cc SHA512 bf43e3a94855b7b12df6a3c88a534c40297df40259e4930dc1b98117b381c5bfaa2e4f17748e731bb6065c02d47ba98d50e336d60cf60e62d4fa0a6b45de53c1
diff --git a/sys-libs/safeclib/files/gh96.patch b/sys-libs/safeclib/files/gh96.patch
deleted file mode 100644
index 83ac48f9c..000000000
--- a/sys-libs/safeclib/files/gh96.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/safeclib_private.h
-+++ b/src/safeclib_private.h
-@@ -52,6 +52,8 @@
- /* Needed since the switch to time64_t */
- #if defined CONFIG_COMPAT_32BIT_TIME && defined _LINUX_TIME64_H && defined __VDSO_TIME32_H
- #define time_t old_time32_t
-+#elif defined _LINUX_TIME64_H && !defined __VDSO_TIME32_H
-+#define time_t time64_t
- #endif
-
- #define RCNEGATE(x) (-(x))
diff --git a/sys-libs/safeclib/files/safeclib-3.7.1-stdarg.patch b/sys-libs/safeclib/files/safeclib-3.7.1-stdarg.patch
new file mode 100644
index 000000000..5a21610cb
--- /dev/null
+++ b/sys-libs/safeclib/files/safeclib-3.7.1-stdarg.patch
@@ -0,0 +1,11 @@
+--- a/Kbuild
++++ b/Kbuild
+@@ -30,7 +30,7 @@
+ # Test module definition
+ obj-m := slkm.o testslkm.o
+
+-ccflags-y := -I$(src)/include -I$(src) -I$(src)/src
++ccflags-y := -I$(src)/include -I$(src) -I$(src)/src -iwithprefix include
+
+ # Functions in the kernel that don't have a 1-to-1 name correlation
+ # __HAVE_ARCH_STRLCPY
diff --git a/sys-libs/safeclib/safeclib-3.6.0_p20210407-r2.ebuild b/sys-libs/safeclib/safeclib-3.6.0_p20210407-r2.ebuild
deleted file mode 100644
index 1488ce394..000000000
--- a/sys-libs/safeclib/safeclib-3.6.0_p20210407-r2.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULE_OPTIONAL_USE=modules
-inherit autotools linux-info linux-mod
-
-MY_REV="986f6d34e49637d68cb41221307231f0ea79ca4d"
-
-DESCRIPTION="safec libc extension with all C11 Annex K functions"
-HOMEPAGE="https://github.com/rurban/safeclib"
-SRC_URI="https://github.com/rurban/safeclib/archive/${MY_REV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+constraint-handler doc +extensions modules norm-compat +nullslack test unsafe valgrind"
-RESTRICT="!test? ( test )"
-PATCHES=( "${FILESDIR}/gh96.patch" )
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
- valgrind? ( dev-util/valgrind )
-"
-
-S="${WORKDIR}/${PN}-${MY_REV}"
-MODULE_NAMES="slkm(misc:${S}:${S})"
-BUILD_TARGETS="all"
-BUILD_PARAMS="-f Makefile.kernel"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK="COMPAT_32BIT_TIME"
- ERROR_COMPAT_32BIT_TIME="module require COMPAT_32BIT_TIME to build"
- fi
- linux-mod_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-
- #duplicate the working folder
- #one for the library and one for the module
- cd "${WORKDIR}" || die
- cp -r "${S}" "${S}-lib" || die
-}
-
-src_configure() {
- export VARTEXFONTS="${T}/fonts"
-
- if use modules ; then
- set_kvobj ko
- econf "${myconf[@]}" --disable-wchar
- fi
-
- cd "${S}-lib" || die
- #forcing wchar because of https://github.com/rurban/safeclib/issues/95
- local myconf=(
- --disable-static
- --disable-valgrind-sgcheck
- --enable-shared
- --disable-Werror
- $(use_enable constraint-handler)
- $(use_enable doc)
- $(use_enable extensions)
- $(use_enable norm-compat)
- $(use_enable nullslack)
- $(use_enable unsafe)
- $(use_enable valgrind)
- )
- econf "${myconf[@]}" --enable-wchar
-}
-
-src_compile() {
- if use modules ; then
- linux-mod_src_compile
- fi
-
- cd "${S}-lib" || die
- default
-}
-
-src_install() {
- if use modules ; then
- linux-mod_src_install
- fi
-
- cd "${S}-lib" || die
- default
- einstalldocs
-
- if use doc ; then
- dodoc -r doc/.
-
- # wcsstr towupper towlower manpages collide with sys-apps/man-pages
- rm "${ED}/usr/share/man/man3/towlower.3" || die
- rm "${ED}/usr/share/man/man3/towupper.3" || die
- rm "${ED}/usr/share/man/man3/wcsstr.3" || die
- fi
-}
-
-src_test() {
- cd "${S}-lib" || die
- emake check
-}
diff --git a/sys-libs/safeclib/safeclib-3.6.0_p20210407-r3.ebuild b/sys-libs/safeclib/safeclib-3.6.0_p20210407-r3.ebuild
deleted file mode 100644
index 38bbdb9d0..000000000
--- a/sys-libs/safeclib/safeclib-3.6.0_p20210407-r3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULE_OPTIONAL_USE=modules
-inherit autotools linux-info linux-mod
-
-MY_REV="986f6d34e49637d68cb41221307231f0ea79ca4d"
-
-DESCRIPTION="safec libc extension with all C11 Annex K functions"
-HOMEPAGE="https://github.com/rurban/safeclib"
-SRC_URI="https://github.com/rurban/safeclib/archive/${MY_REV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+constraint-handler doc +extensions modules norm-compat +nullslack test unsafe valgrind"
-RESTRICT="!test? ( test )"
-PATCHES=( "${FILESDIR}/gh96.patch" )
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
- valgrind? ( dev-util/valgrind )
-"
-
-S="${WORKDIR}/${PN}-${MY_REV}"
-MODULE_NAMES="slkm(misc:${S}:${S})"
-BUILD_TARGETS="all"
-BUILD_PARAMS="-f Makefile.kernel"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK="COMPAT_32BIT_TIME"
- ERROR_COMPAT_32BIT_TIME="module require COMPAT_32BIT_TIME to build"
- fi
- linux-mod_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-
- #duplicate the working folder
- #one for the library and one for the module
- cd "${WORKDIR}" || die
- cp -r "${S}" "${S}-lib" || die
-}
-
-src_configure() {
- export VARTEXFONTS="${T}/fonts"
-
- if use modules ; then
- set_kvobj ko
- econf "${myconf[@]}" --disable-wchar
- fi
-
- cd "${S}-lib" || die
- #forcing wchar because of https://github.com/rurban/safeclib/issues/95
- local myconf=(
- --disable-static
- --disable-valgrind-sgcheck
- --enable-shared
- --disable-Werror
- $(use_enable constraint-handler)
- $(use_enable doc)
- $(use_enable extensions)
- $(use_enable norm-compat)
- $(use_enable nullslack)
- $(use_enable unsafe)
- $(use_enable valgrind)
- )
- econf "${myconf[@]}" --enable-wchar
-}
-
-src_compile() {
- if use modules ; then
- linux-mod_src_compile
- fi
-
- cd "${S}-lib" || die
- default
-}
-
-src_install() {
- if use modules ; then
- linux-mod_src_install
- fi
-
- cd "${S}-lib" || die
- default
- einstalldocs
-
- if use doc ; then
- rm -rf doc/man || die
- dodoc -r doc/.
- docompress -x "/usr/share/doc/${PF}/html"
-
- # wcsstr towupper towlower manpages collide with sys-apps/man-pages
- rm "${ED}/usr/share/man/man3/towlower.3" || die
- rm "${ED}/usr/share/man/man3/towupper.3" || die
- rm "${ED}/usr/share/man/man3/wcsstr.3" || die
- fi
-}
-
-src_test() {
- cd "${S}-lib" || die
- emake check
-}
diff --git a/sys-libs/safeclib/safeclib-3.7.1.ebuild b/sys-libs/safeclib/safeclib-3.7.1-r1.ebuild
index 4d0a501f7..334387d82 100644
--- a/sys-libs/safeclib/safeclib-3.7.1.ebuild
+++ b/sys-libs/safeclib/safeclib-3.7.1-r1.ebuild
@@ -22,9 +22,11 @@ BDEPEND="
valgrind? ( dev-util/valgrind )
"
+PATCHES=( "${FILESDIR}/${P}-stdarg.patch" )
+
MODULE_NAMES="slkm(misc:${S}:${S})"
BUILD_TARGETS="all"
-BUILD_PARAMS="-f Makefile.kernel"
+BUILD_PARAMS="-f Makefile.kernel V=1"
pkg_setup() {
if use modules ; then
@@ -64,7 +66,7 @@ src_configure() {
if use modules ; then
set_kvobj ko
- econf "${myconf[@]}" --disable-wchar
+ ECONF_PARAMS="${myconf[@]} --disable-wchar"
fi
cd "${S}-lib" || die