aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-05-15 03:19:30 -0400
committerJoe Kappus <joe@wt.gd>2024-05-15 03:22:06 -0400
commite5c92ddd9f009b25f033d77bc860ad33528e3f62 (patch)
treea1573e543d407da268b11595dccc35e35454492f /sys-power
parentnet-misc/maestral: update dependency on dev-python/dropbox (diff)
downloadguru-e5c92ddd9f009b25f033d77bc860ad33528e3f62.tar.gz
guru-e5c92ddd9f009b25f033d77bc860ad33528e3f62.tar.bz2
guru-e5c92ddd9f009b25f033d77bc860ad33528e3f62.zip
sys-power/linux-tools-power-x86/files: drop -D_FORTIFY_SOURCE=2 from CFLAGS
Closes: https://bugs.gentoo.org/931935 Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch33
-rw-r--r--sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch16
2 files changed, 32 insertions, 17 deletions
diff --git a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
index 499bbce0d..8de8139d8 100644
--- a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
+++ b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
@@ -1,7 +1,8 @@
-diff -urN a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-speed-select/Makefile
---- a/tools/power/x86/intel-speed-select/Makefile 2022-12-11 17:15:18.000000000 -0500
-+++ b/tools/power/x86/intel-speed-select/Makefile 2023-02-04 05:47:25.961523494 -0500
-@@ -13,7 +13,7 @@
+diff --git a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-speed-select/Makefile
+index 7221f2f55e8b..96b5a456a4c5 100644
+--- a/tools/power/x86/intel-speed-select/Makefile
++++ b/tools/power/x86/intel-speed-select/Makefile
+@@ -13,7 +13,7 @@ endif
# Do not use make's built-in rules
# (this improves performance and avoids hard-to-debug behaviour);
MAKEFLAGS += -r
@@ -10,10 +11,11 @@ diff -urN a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-
override LDFLAGS += -lnl-genl-3 -lnl-3
ALL_TARGETS := intel-speed-select
-diff -urN a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makefile
---- a/tools/power/x86/turbostat/Makefile 2022-12-11 17:15:18.000000000 -0500
-+++ b/tools/power/x86/turbostat/Makefile 2023-02-04 05:49:01.960951027 -0500
-@@ -9,7 +9,7 @@
+diff --git a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makefile
+index 92e139b9c792..d2c21035e16d 100644
+--- a/tools/power/x86/turbostat/Makefile
++++ b/tools/power/x86/turbostat/Makefile
+@@ -9,11 +9,10 @@ ifeq ("$(origin O)", "command line")
endif
turbostat : turbostat.c
@@ -22,10 +24,15 @@ diff -urN a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makef
override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
override CFLAGS += -DINTEL_FAMILY_HEADER='"../../../../arch/x86/include/asm/intel-family.h"'
override CFLAGS += -D_FILE_OFFSET_BITS=64
-diff -urN a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x86_energy_perf_policy/Makefile
---- a/tools/power/x86/x86_energy_perf_policy/Makefile 2022-12-11 17:15:18.000000000 -0500
-+++ b/tools/power/x86/x86_energy_perf_policy/Makefile 2023-02-04 05:47:25.962523488 -0500
-@@ -9,7 +9,6 @@
+-override CFLAGS += -D_FORTIFY_SOURCE=2
+
+ %: %.c
+ @mkdir -p $(BUILD_OUTPUT)
+diff --git a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x86_energy_perf_policy/Makefile
+index 666b325a62a2..1fdeef864e7c 100644
+--- a/tools/power/x86/x86_energy_perf_policy/Makefile
++++ b/tools/power/x86/x86_energy_perf_policy/Makefile
+@@ -9,9 +9,8 @@ ifeq ("$(origin O)", "command line")
endif
x86_energy_perf_policy : x86_energy_perf_policy.c
@@ -34,3 +41,5 @@ diff -urN a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x8
override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
-override CFLAGS += -D_FORTIFY_SOURCE=2
+ %: %.c
+ @mkdir -p $(BUILD_OUTPUT)
diff --git a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch
index 111fb1a88..8de8139d8 100644
--- a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch
+++ b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch
@@ -12,10 +12,10 @@ index 7221f2f55e8b..96b5a456a4c5 100644
ALL_TARGETS := intel-speed-select
diff --git a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makefile
-index 92e139b9c792..972fb3c5a514 100644
+index 92e139b9c792..d2c21035e16d 100644
--- a/tools/power/x86/turbostat/Makefile
+++ b/tools/power/x86/turbostat/Makefile
-@@ -9,7 +9,7 @@ ifeq ("$(origin O)", "command line")
+@@ -9,11 +9,10 @@ ifeq ("$(origin O)", "command line")
endif
turbostat : turbostat.c
@@ -24,16 +24,22 @@ index 92e139b9c792..972fb3c5a514 100644
override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
override CFLAGS += -DINTEL_FAMILY_HEADER='"../../../../arch/x86/include/asm/intel-family.h"'
override CFLAGS += -D_FILE_OFFSET_BITS=64
+-override CFLAGS += -D_FORTIFY_SOURCE=2
+
+ %: %.c
+ @mkdir -p $(BUILD_OUTPUT)
diff --git a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x86_energy_perf_policy/Makefile
-index 666b325a62a2..0053893229fb 100644
+index 666b325a62a2..1fdeef864e7c 100644
--- a/tools/power/x86/x86_energy_perf_policy/Makefile
+++ b/tools/power/x86/x86_energy_perf_policy/Makefile
-@@ -9,7 +9,7 @@ ifeq ("$(origin O)", "command line")
+@@ -9,9 +9,8 @@ ifeq ("$(origin O)", "command line")
endif
x86_energy_perf_policy : x86_energy_perf_policy.c
-override CFLAGS += -O2 -Wall -I../../../include
+override CFLAGS += -Wall -I../../../include
override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
- override CFLAGS += -D_FORTIFY_SOURCE=2
+-override CFLAGS += -D_FORTIFY_SOURCE=2
+ %: %.c
+ @mkdir -p $(BUILD_OUTPUT)