aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ananicy-cpp/ananicy-cpp-1.0.0_rc6-r1.ebuild')
-rw-r--r--app-admin/ananicy-cpp/ananicy-cpp-1.0.0_rc6-r1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-admin/ananicy-cpp/ananicy-cpp-1.0.0_rc6-r1.ebuild b/app-admin/ananicy-cpp/ananicy-cpp-1.0.0_rc6-r1.ebuild
deleted file mode 100644
index bfe106080..000000000
--- a/app-admin/ananicy-cpp/ananicy-cpp-1.0.0_rc6-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ANANICY_COMMIT="9180bb4511e2de5229428303df1a4954b0c516d9" # for rules
-MYPV="${PV/_rc/-rc}"
-
-inherit cmake
-
-DESCRIPTION="Ananicy rewritten in C++ for much lower CPU and memory usage"
-HOMEPAGE="https://gitlab.com/ananicy-cpp/ananicy-cpp"
-SRC_URI="
- https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v${MYPV}/${PN}-v${MYPV}.tar.bz2
- https://github.com/kuche1/minq-ananicy/archive/${ANANICY_COMMIT}.tar.gz -> minq-ananicy-${ANANICY_COMMIT}.tar.gz
-"
-S="${WORKDIR}/${PN}-v${MYPV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="systemd"
-
-RDEPEND="
- dev-cpp/nlohmann_json
- dev-libs/libfmt
- dev-libs/spdlog
- systemd? ( sys-apps/systemd )
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/std-format
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-system-std-format.patch"
- "${FILESDIR}/${P}-respect-flags.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_SYSTEMD=$(usex systemd)
- -DUSE_EXTERNAL_FMTLIB=ON
- -DUSE_EXTERNAL_JSON=ON
- -DUSE_EXTERNAL_SPDLOG=ON
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- doinitd "${FILESDIR}/${PN}.initd"
- insinto /etc
- doins -r "${WORKDIR}/minq-ananicy-${ANANICY_COMMIT}/ananicy.d"
-}