aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-1.31.0-r1.ebuild')
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-1.31.0-r1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-1.31.0-r1.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-1.31.0-r1.ebuild
deleted file mode 100644
index 572a0e9816..0000000000
--- a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-1.31.0-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-PARENT_PN="${PN%-dns-rfc2136}"
-PARENT_P="${PARENT_PN}-${PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/certbot/certbot/archive/v${PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-fi
-
-DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
-HOMEPAGE="
- https://letsencrypt.org/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
-BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-22.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3.0.9[${PYTHON_USEDEP}]
- >=dev-python/zope-interface-5.4.0[${PYTHON_USEDEP}]
- >=dev-python/dnspython-2.2.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-# Same than PATCHES but from repository's root directory,
-# please see function `python_prepare_all` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "${PN}" subdirectory.
-PATCHES=(
-)
-
-python_prepare_all() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}