aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/rainbow_csv/rainbow_csv-1.10.0_pre20240705.ebuild')
-rw-r--r--app-vim/rainbow_csv/rainbow_csv-1.10.0_pre20240705.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/rainbow_csv/rainbow_csv-1.10.0_pre20240705.ebuild b/app-vim/rainbow_csv/rainbow_csv-1.10.0_pre20240705.ebuild
new file mode 100644
index 000000000..9af59c05e
--- /dev/null
+++ b/app-vim/rainbow_csv/rainbow_csv-1.10.0_pre20240705.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit vim-plugin
+
+DESCRIPTION="🌈Rainbow CSV - Vim plugin: Highlight columns in CSV and TSV files and run queries in SQL-like language"
+HOMEPAGE="https://github.com/mechatroner/rainbow_csv"
+
+EGIT_COMMIT="3dbbfd7d17536aebfb80f571255548495574c32b"
+MY_P="${PN}-${EGIT_COMMIT}"
+SRC_URI="https://github.com/mechatroner/rainbow_csv/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-editors/vim
+"
+
+src_install() {
+ vim-plugin_src_install
+}