aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-nim/cligen/cligen-1.5.40.ebuild')
-rw-r--r--dev-nim/cligen/cligen-1.5.40.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-nim/cligen/cligen-1.5.40.ebuild b/dev-nim/cligen/cligen-1.5.40.ebuild
new file mode 100644
index 000000000..19f77f5f5
--- /dev/null
+++ b/dev-nim/cligen/cligen-1.5.40.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit nimble
+
+DESCRIPTION="Infer & generate command-line interface/option/argument parser"
+HOMEPAGE="
+ https://github.com/c-blake/cligen
+ https://nimble.directory/pkg/cligen
+"
+SRC_URI="https://github.com/c-blake/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC MIT"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+# Version.nim test fails
+RESTRICT="test"
+
+DOCS=( configs {MOTIVATION,README,RELEASE-NOTES,TODO}.md )
+
+set_package_url "https://github.com/c-blake/cligen"
+
+src_test() {
+ emake -f GNUmakefile
+}
+
+src_install() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+
+ nimble_src_install
+}