aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-install/ruby-install-0.8.5.ebuild')
-rw-r--r--dev-ruby/ruby-install/ruby-install-0.8.5.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/ruby-install/ruby-install-0.8.5.ebuild b/dev-ruby/ruby-install/ruby-install-0.8.5.ebuild
deleted file mode 100644
index 706d5e5d2..000000000
--- a/dev-ruby/ruby-install/ruby-install-0.8.5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Installs Ruby, JRuby, Rubinius, TruffleRuby (native / GraalVM), or mruby."
-HOMEPAGE="https://github.com/postmodern/ruby-install"
-SRC_URI="https://github.com/postmodern/ruby-install/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-PROPERTIES="test_network"
-RESTRICT="!test? ( test )"
-
-DEPEND=">=app-shells/bash-3.0:*"
-RDEPEND="${DEPEND}
- sys-apps/grep
- || ( >net-misc/wget-1.12 net-misc/curl )
- dev-libs/openssl
- app-arch/tar
- app-arch/bzip2
- app-arch/xz-utils
- sys-devel/patch
- || ( >=sys-devel/gcc-4.2 sys-devel/clang )"
-BDEPEND="test? ( dev-util/shunit2 )"
-
-# XXX: `make check` seems to be broken (violates shellcheck tests)
-src_test() {
- emake test
-}
-
-src_prepare() {
- default
-
- sed -i Makefile -e "s/^VERSION=.\+$/VERSION=${PVR}/" \
- || die "Cannot fix doc location to follow Gentoo/FHS guidelines"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
-}