aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/aaaaxy/aaaaxy-1.3.263.ebuild')
-rw-r--r--games-puzzle/aaaaxy/aaaaxy-1.3.263.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-puzzle/aaaaxy/aaaaxy-1.3.263.ebuild b/games-puzzle/aaaaxy/aaaaxy-1.3.263.ebuild
new file mode 100644
index 000000000..5a1c9b6a2
--- /dev/null
+++ b/games-puzzle/aaaaxy/aaaaxy-1.3.263.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop go-module
+
+DEPS_DATE="2023-02-07" # when the deps archive has been created
+
+DESCRIPTION="A nonlinear 2D puzzle platformer taking place in impossible spaces"
+HOMEPAGE="https://divverent.github.io/aaaaxy/"
+SRC_URI="
+ https://github.com/divVerent/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gitlab.com/api/v4/projects/41581401/packages/generic/${PN}/${PV}+${DEPS_DATE}/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD MIT || ( FTL GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="bindist" # only redistributable when using Freetype under FTL
+
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+"
+
+src_configure() {
+ GOFLAGS+=" -buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+}
+
+src_compile() {
+ emake AAAAXY_BUILD_USE_VERSION_FILE=true BUILDTYPE=release
+}
+
+src_install() {
+ dobin ${PN}
+ doicon -s scalable ${PN}.svg
+ doicon -s 128 ${PN}.png
+ domenu ${PN}.desktop
+}