aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/corestats/corestats-4.2.0.ebuild')
-rw-r--r--gui-apps/corestats/corestats-4.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/gui-apps/corestats/corestats-4.2.0.ebuild b/gui-apps/corestats/corestats-4.2.0.ebuild
new file mode 100644
index 000000000..6add84b37
--- /dev/null
+++ b/gui-apps/corestats/corestats-4.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="A system resource viewer for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/corestats"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+ gui-libs/libcsys
+ sys-apps/lm-sensors
+"
+RDEPEND="
+ ${DEPEND}
+"