aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fooyin/Manifest1
-rw-r--r--media-sound/fooyin/fooyin-0.7.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/media-sound/fooyin/Manifest b/media-sound/fooyin/Manifest
index c01c3e5fb..648657161 100644
--- a/media-sound/fooyin/Manifest
+++ b/media-sound/fooyin/Manifest
@@ -1,2 +1,3 @@
DIST fooyin-0.7.0.tar.gz 1575492 BLAKE2B 0c06fb301b43de3f718efba479159cb5be7182a1a60371a04da27ebd302fb500816b10b841184290a428e08f46034cb4fe71185dbabb408637080eb2fb99ebf9 SHA512 70220d0503e473b347633d1d602d95fed4b78f4f2b7caa3b4a75854e622182eecd622b9f92434030097f5ab0926f305a948d16c0f776536b4ab562f94fe5bd76
DIST fooyin-0.7.1.tar.gz 1584531 BLAKE2B e6ef313e45a5834eb4a0f331f45d803ae09a723acac08fc52bb77996c32fba38c4f7a49c8c3f6e96ecdcc30523a45d184217c59f4d1d7e8221fcd92f492c7c29 SHA512 0925f4f8db43446bdd62e2ad2df34f6e60dab5d27dd0423fd9d4ff6b50556bcebb658140303ae0697dbff97762e48a21ed2d5918f23782bd098161aefaddb248
+DIST fooyin-0.7.2.tar.gz 1592767 BLAKE2B 548200ebf635f69c085cb6c1bb87dece374ce68173386f2fbfc0abe6b3594dfde35fc01beb542e6a90146a5e27c9e0ac58e319eb5a7a9d184d3a87f9ee185ecf SHA512 aed08bca5f8e56843fa844f874efa6d59d4213b7f3c2852a620518097c19fa5a68205d7234a3563e32fa383456648e4fb0719a2973b4ec9a55d4e14af56314eb
diff --git a/media-sound/fooyin/fooyin-0.7.2.ebuild b/media-sound/fooyin/fooyin-0.7.2.ebuild
new file mode 100644
index 000000000..fb1680cf6
--- /dev/null
+++ b/media-sound/fooyin/fooyin-0.7.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="A customizable music player, Qt clone of foobar2000"
+HOMEPAGE="https://www.fooyin.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fooyin/fooyin.git"
+else
+ SRC_URI="
+ https://github.com/fooyin/fooyin/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="alsa +archive openmpt pipewire sdl test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ || ( alsa pipewire sdl )
+"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/kdsingleapplication
+ dev-qt/qtbase:6[concurrent,dbus,gui,network,sql,widgets]
+ dev-qt/qtsvg:6
+ media-libs/taglib
+ media-video/ffmpeg:=
+ alsa? ( media-libs/alsa-lib )
+ archive? ( app-arch/libarchive:= )
+ openmpt? ( media-libs/libopenmpt )
+ pipewire? ( media-video/pipewire:= )
+ sdl? ( media-libs/libsdl2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+"
+
+src_prepare() {
+ sed -i CMakeLists.txt \
+ -e "s|/doc/${PN}|/doc/${PF}|g" \
+ -e '/option(BUILD_TESTING/aenable_testing()' \
+ || die
+
+ sed \
+ -e "s#:/audio#data/audio#g" \
+ -i \
+ tests/tagwritertest.cpp \
+ tests/tagreadertest.cpp \
+ || die
+
+ cmake_src_prepare
+}
+
+# libvgm, sndfile and libgme dependencies can currently not be satisfied,
+# so building their input plugins is unconditionally disabled for now.
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ALSA=$(usex alsa)
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_CCACHE=OFF
+ -DBUILD_LIBVGM=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_LIBGME=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_SndFile=ON
+ -DINSTALL_HEADERS=ON
+ $(cmake_use_find_package archive LibArchive)
+ $(cmake_use_find_package openmpt OpenMpt)
+ $(cmake_use_find_package pipewire PipeWire)
+ $(cmake_use_find_package sdl SDL2)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ ln -sr "${CMAKE_USE_DIR}/tests/data/audio" "${BUILD_DIR}/tests/data/audio" || die
+
+ cmake_src_test
+}