aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/tio/tio-3.6.ebuild')
-rw-r--r--net-dialup/tio/tio-3.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-dialup/tio/tio-3.6.ebuild b/net-dialup/tio/tio-3.6.ebuild
new file mode 100644
index 000000000..dead597a8
--- /dev/null
+++ b/net-dialup/tio/tio-3.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/glib
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}