aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild')
-rw-r--r--sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild b/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild
index cd801deea..53099d358 100644
--- a/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild
+++ b/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake fortran-2
+inherit cmake fortran-2 toolchain-funcs
DESCRIPTION="Mathematical software for solving large-scale dense linear systems"
HOMEPAGE="https://github.com/liuyangzhuan/ButterflyPACK"
@@ -29,11 +29,12 @@ DOCS=( README.md CHANGELOG )
PATCHES=( "${FILESDIR}/${P}-no-examples.patch" )
src_configure() {
+ local pkgc="$(tc-getPKG_CONFIG)"
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
- -DTPL_ARPACK_LIBRARIES=$(usex arpack)
- -DTPL_MAGMA_LIBRARIES=$(usex magma)
+ "-DTPL_ARPACK_LIBRARIES=$(${pkgc} --libs arpack)"
+ "-DTPL_MAGMA_LIBRARIES=$(${pkgc} --libs magma)"
)
cmake_src_configure
}