summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unzip/unzip-5.52-r2.ebuild')
-rw-r--r--app-arch/unzip/unzip-5.52-r2.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/app-arch/unzip/unzip-5.52-r2.ebuild b/app-arch/unzip/unzip-5.52-r2.ebuild
deleted file mode 100644
index d0226d253d..0000000000
--- a/app-arch/unzip/unzip-5.52-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r2.ebuild,v 1.8 2008/10/23 02:46:26 flameeyes Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="unzipper for pkzip-compressed files"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://gentoo/${PN}${PV/.}.tar.gz"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-no-exec-stack.patch
- epatch "${FILESDIR}"/${P}-CVE-2008-0888.patch #213761
- sed -i \
- -e 's:-O3:$(CFLAGS) $(CPPFLAGS):' \
- -e 's:-O :$(CFLAGS) $(CPPFLAGS) :' \
- -e "s:CC=gcc :CC=$(tc-getCC) :" \
- -e "s:LD=gcc :LD=$(tc-getCC) :" \
- -e "s:AS=gcc :AS=$(tc-getCC) :" \
- -e 's:LF2 = -s:LF2 = :' \
- -e 's:LF = :LF = $(LDFLAGS) :' \
- -e 's:SL = :SL = $(LDFLAGS) :' \
- -e 's:FL = :FL = $(LDFLAGS) :' \
- -e 's:STRIP =.*$:STRIP = true:' \
- unix/Makefile \
- || die "sed unix/Makefile failed"
-}
-
-src_compile() {
- local TARGET
- case ${CHOST} in
- i?86*-linux*) TARGET=linux_asm ;;
- *-linux*) TARGET=linux_noasm ;;
- i?86*-freebsd* | i?86*-dragonfly* | i?86*-openbsd* | i?86*-netbsd*)
- TARGET=freebsd ;; # mislabelled bsd with x86 asm
- *-freebsd* | *-dragonfly* | *-openbsd* | *-netbsd*)
- TARGET=bsd ;;
- *-darwin*) TARGET=macosx ;;
- *-solaris*) TARGET=solaris ;;
- mips-sgi-irix*) TARGET=sgi ;;
- *-interix*) TARGET=gcc; append-flags "-DUNIX" ;;
- *-aix*) TARGET=gcc ;;
- *-mint*) TARGET=generic ;;
- *) die "Unknown target, you suck" ;;
- esac
- append-lfs-flags #104315
- emake -f unix/Makefile ${TARGET} || die "emake failed"
-}
-
-src_install() {
- dobin unzip funzip unzipsfx unix/zipgrep || die "dobin failed"
- dosym unzip /usr/bin/zipinfo || die
- doman man/*.1
- dodoc BUGS History* README ToDo WHERE
-}