aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormpkh <cynede@gentoo.org>2018-01-26 11:53:54 +0400
committerGitHub <noreply@github.com>2018-01-26 11:53:54 +0400
commit60fa0bf4c41806b03e7cb739bf91c1baf3c51da1 (patch)
tree69a9560151201d5421535017bab5514ced96b99b /dev-util
parentrevert old rust-9999 ebuild (for PR) (diff)
parentUse separate lidir. Use cargo from rust distribution. (diff)
downloadrust-60fa0bf4c41806b03e7cb739bf91c1baf3c51da1.tar.gz
rust-60fa0bf4c41806b03e7cb739bf91c1baf3c51da1.tar.bz2
rust-60fa0bf4c41806b03e7cb739bf91c1baf3c51da1.zip
Merge pull request #317 from o01eg/master
Use separate lidir. Use cargo from rust distribution.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cargo/cargo-9999.ebuild49
1 files changed, 5 insertions, 44 deletions
diff --git a/dev-util/cargo/cargo-9999.ebuild b/dev-util/cargo/cargo-9999.ebuild
index 92e6d1b..3b284df 100644
--- a/dev-util/cargo/cargo-9999.ebuild
+++ b/dev-util/cargo/cargo-9999.ebuild
@@ -3,54 +3,15 @@
EAPI=6
-inherit eutils bash-completion-r1 git-r3
-
-DESCRIPTION="The Rust's package manager"
+DESCRIPTION="The Rust's package manager (virtual package)"
HOMEPAGE="http://crates.io/"
+SRC_URI=""
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
KEYWORDS=""
-IUSE="libressl"
-
-EGIT_REPO_URI="https://github.com/rust-lang/cargo.git"
-BIN_CARGO_URI="https://static.rust-lang.org/dist/cargo-nightly"
-
-COMMON_DEPEND=">=virtual/rust-999
- sys-libs/zlib
- !libressl? ( dev-libs/openssl:* )
- libressl? ( dev-libs/libressl:0 )
- net-libs/libssh2
- net-libs/http-parser"
-RDEPEND="${COMMON_DEPEND}
- net-misc/curl[ssl]"
-DEPEND="${COMMON_DEPEND}
- dev-util/cmake"
-
-DOCS="LICENSE-APACHE LICENSE-MIT LICENSE-THIRD-PARTY README.md"
-
-pkg_setup() {
- local postfix
- use amd64 && postfix=x86_64-unknown-linux-gnu
- use x86 && postfix=i686-unknown-linux-gnu
-
- # Download nightly cargo to bootstrap from it
-
- wget "${BIN_CARGO_URI}-${postfix}.tar.gz" || die
- unpack "./cargo-nightly-${postfix}.tar.gz"
- mv "./cargo-nightly-${postfix}" "./cargo"
-}
-
-src_compile() {
- "$HOME/cargo/cargo/bin/cargo" build --release || die
-}
+DEPEND=""
+RDEPEND=""
+PDEPEND=">=dev-lang/rust-9999[tools]"
-src_install() {
- default
- dobin target/release/${PN}
- doman src/etc/man/${PN}*.1
- newbashcomp src/etc/cargo.bashcomp.sh cargo
- insinto /usr/share/zsh/site-functions
- doins src/etc/_cargo
-}