summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 21:36:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 22:12:00 +0200
commit14cf11eeda5db1955f587f5fb6655f4da67b856d (patch)
treecaf1813f124441587d87986ef312d8c23820af97
parentdev-python/psutil: Reenable tests on pypy3 (diff)
downloadgentoo-14cf11eeda5db1955f587f5fb6655f4da67b856d.tar.gz
gentoo-14cf11eeda5db1955f587f5fb6655f4da67b856d.tar.bz2
gentoo-14cf11eeda5db1955f587f5fb6655f4da67b856d.zip
dev-python/pytest-forked: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..ea35730f0141
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="
+ https://pypi.org/project/pytest-forked/
+ https://github.com/pytest-dev/pytest-forked/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}