summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2025-01-05 19:03:29 -0500
committerMike Pagano <mpagano@gentoo.org>2025-01-05 19:03:40 -0500
commit14eeafda035d6805148124b96e85a3b9d3271f2a (patch)
tree217d626cc40ff07a693a898ebd560e2e5e0930df
parentmedia-plugins/gst-plugins-vaapi: depend on libva[wayland] (diff)
downloadgentoo-14eeafda035d6805148124b96e85a3b9d3271f2a.tar.gz
gentoo-14eeafda035d6805148124b96e85a3b9d3271f2a.tar.bz2
gentoo-14eeafda035d6805148124b96e85a3b9d3271f2a.zip
sys-kernel/git-sources: add 6.13_rc6
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.13_rc6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index a3f0c6429680..9e0438b09e5a 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-6.13-rc2.patch 45755252 BLAKE2B 8ab895aba64d944bd79a0d0ccb9fb61cb243b
DIST patch-6.13-rc3.patch 46670516 BLAKE2B ba0e0bff8c1f32d81b9d5b7fd9f777d3c3b46c7504978ac4d2ec7e66668b1d39ce48ee16b875de0f8a10754237d4ad1944999236a299ee443de05b52deb06a9a SHA512 055ab3a368f3ef1000912c973121d373a108998253240dad1d1ce9cbbc9ecae52a06bab1b89d659a56cce127a9605e46c0997aaeafe01724fcc9df0d63534806
DIST patch-6.13-rc4.patch 46999276 BLAKE2B db5ffe5407033057000a7b6003e7e33c1df39a00e23687228922bf6d25467eaa4a961b4db0bb7a6ae666ca292a81d16a7c941430531a350d058c7013f462fe4f SHA512 0231c8374a24711345cbf88a4ba5a617c0ab22be42053567d53a5a8cbbde57a0ae6dc27d6e1537daaec72b863888bd87be0ef4f5738f814ec5ecefc20abd1816
DIST patch-6.13-rc5.patch 47079185 BLAKE2B 72e044c4fa41d44d9c61a695c38f40bd617642ec9e65978128a04ea6a514708a5634d409bf3ca10621b636ae1fee888f916a7454ff13e123e07f06cc0d403f86 SHA512 de639760efbf7a2de077003a81e9d9d1dc20df36d9325799377dc7c608fd68c8f4cb5c14e455f8c0561b63a4cd4fca1e70524eacdd3d53b1a60e86afd1cd4fe5
+DIST patch-6.13-rc6.patch 47284877 BLAKE2B e87ea7991218b210e6c455fb635d28794bedc3130e94d888d19f622f871b45096b165d8d3c4d73dd6a2a992474253a218fd4a812413c2dcffe3b4b39fa8dbda8 SHA512 29121085799cda1359e4bb758118f5decc4ff2e911114a716979a493d7e8c0100a0aef2225dc75bf73043bf56cb48be8b686e02d93a2b4c9984c59c1b2c4c9af
diff --git a/sys-kernel/git-sources/git-sources-6.13_rc6.ebuild b/sys-kernel/git-sources/git-sources-6.13_rc6.ebuild
new file mode 100644
index 000000000000..31f6629155fc
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.13_rc6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.12"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r5"
+
+pkg_postinst() {
+ postinst_sources
+}