summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-07 23:06:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-07 23:10:11 +0300
commit168fba9fb7575277042ac5a1329682a957788470 (patch)
tree4fb8e2aef386eae73e7bc5b1bcbfd3dc2d07a6f5
parentapp-backup/attic: treeclean (diff)
downloadgentoo-168fba9fb7575277042ac5a1329682a957788470.tar.gz
gentoo-168fba9fb7575277042ac5a1329682a957788470.tar.bz2
gentoo-168fba9fb7575277042ac5a1329682a957788470.zip
www-apps/blohg: treeclean
Closes: https://bugs.gentoo.org/869107 Closes: https://bugs.gentoo.org/832256 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--profiles/package.mask5
-rw-r--r--www-apps/blohg/Manifest2
-rw-r--r--www-apps/blohg/blohg-0.13-r4.ebuild78
-rw-r--r--www-apps/blohg/blohg-9999.ebuild78
-rw-r--r--www-apps/blohg/metadata.xml26
5 files changed, 0 insertions, 189 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 8702c9842459..3f6158c87170 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -259,11 +259,6 @@ dev-python/SaltTesting
# Bug #868762.
=dev-util/pahole-1.24
-# Arthur Zamarin <arthurzam@gentoo.org> (2022-09-07)
-# Python 3.8 only package, no maintainer left.
-# Removal: 2022-10-07. Bug #869107.
-www-apps/blohg
-
# Mike Gilbert <floppym@gentoo.org> (2022-09-05)
# Crash due to double-free.
# https://bugs.gentoo.org/868567
diff --git a/www-apps/blohg/Manifest b/www-apps/blohg/Manifest
deleted file mode 100644
index 8d8bcd4e9d73..000000000000
--- a/www-apps/blohg/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST blohg-0.13.tar.gz 75003 BLAKE2B 6b9760ffa99ca85a40e35c81341e395fdfc00256f5e80091c6883e54f050d4cf3f345c4752b635b1297d15e0055c182e00e74165451d695bb396c869c285646f SHA512 de8643e85e3f72827408d726bbe2f8674dcc6dcf1efdc47d33a934892071f8365cb54e63a6adb803361c7fd04032b2ac4e786c442676e8a8132b6d3221696865
-DIST blohg-patches-0.13-r4.tar.xz 14960 BLAKE2B 31458f412395000a05b359db25e8af648c54e554a3b3216f6c62355fd7203fc19c4452defe7692d0382653563f7b0565395af4ceb2177cc8e6de1d7e1a3c7b41 SHA512 3f709880bdd1826b74982866931f5002fdda451a205b6c278a9869979314413f37c8bf6400e3064a463f2fd34810e22d0d4cd5dfc89786f9e276dd9bd9fe5ec2
diff --git a/www-apps/blohg/blohg-0.13-r4.ebuild b/www-apps/blohg/blohg-0.13-r4.ebuild
deleted file mode 100644
index 82259f3e10b6..000000000000
--- a/www-apps/blohg/blohg-0.13-r4.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-GIT_ECLASS=""
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/rafaelmartins/blohg"
-fi
-
-inherit distutils-r1 ${GIT_ECLASS}
-
-DESCRIPTION="A Mercurial (or Git) based blogging engine"
-HOMEPAGE="https://github.com/rafaelmartins/blohg"
-
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~rafaelmartins/distfiles/${PN}-patches-${PVR}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc git +mercurial test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="|| ( git mercurial )
- test? ( git mercurial )"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/feedgenerator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- dev-python/Frozen-Flask[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- git? ( dev-python/pygit2[${PYTHON_USEDEP}] )
- mercurial? ( >=dev-vcs/mercurial-5.2[${PYTHON_USEDEP}] )"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-python_prepare_all() {
- if [[ ${PV} != *9999* ]]; then
- eapply "${WORKDIR}/${PN}-patches-${PVR}"
- fi
-
- if ! use git; then
- rm -rf blohg/vcs_backends/git || die 'rm failed'
- fi
-
- if ! use mercurial; then
- rm -rf blohg/vcs_backends/hg || die 'rm failed'
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/www-apps/blohg/blohg-9999.ebuild b/www-apps/blohg/blohg-9999.ebuild
deleted file mode 100644
index 82259f3e10b6..000000000000
--- a/www-apps/blohg/blohg-9999.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-GIT_ECLASS=""
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/rafaelmartins/blohg"
-fi
-
-inherit distutils-r1 ${GIT_ECLASS}
-
-DESCRIPTION="A Mercurial (or Git) based blogging engine"
-HOMEPAGE="https://github.com/rafaelmartins/blohg"
-
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~rafaelmartins/distfiles/${PN}-patches-${PVR}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc git +mercurial test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="|| ( git mercurial )
- test? ( git mercurial )"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/feedgenerator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- dev-python/Frozen-Flask[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- git? ( dev-python/pygit2[${PYTHON_USEDEP}] )
- mercurial? ( >=dev-vcs/mercurial-5.2[${PYTHON_USEDEP}] )"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-python_prepare_all() {
- if [[ ${PV} != *9999* ]]; then
- eapply "${WORKDIR}/${PN}-patches-${PVR}"
- fi
-
- if ! use git; then
- rm -rf blohg/vcs_backends/git || die 'rm failed'
- fi
-
- if ! use mercurial; then
- rm -rf blohg/vcs_backends/hg || die 'rm failed'
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/www-apps/blohg/metadata.xml b/www-apps/blohg/metadata.xml
deleted file mode 100644
index 18003f748147..000000000000
--- a/www-apps/blohg/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <stabilize-allarches/>
- <longdescription lang="en">
- blohg is a Mercurial (or Git) based blogging engine written in Python,
- built with the Flask micro-framework and some of his available extensions.
- All the content of the blogs are stored inside repositories and the
- repository history is used for build the posts and pages. blohg uses
- Jinja2 as template engine.
- </longdescription>
- <upstream>
- <maintainer status="active">
- <email>rafaelmartins@gentoo.org</email>
- <name>Rafael G. Martins</name>
- </maintainer>
- <bugs-to>mailto:blohg@librelist.com</bugs-to>
- <remote-id type="pypi">blohg</remote-id>
- <remote-id type="github">rafaelmartins/blohg</remote-id>
- </upstream>
- <use>
- <flag name="git">Enable Git support</flag>
- <flag name="mercurial">Enable Mercurial support</flag>
- </use>
-</pkgmetadata>