summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-05 23:32:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-06 01:42:58 +0100
commit35ea90bf7fd2e99c9e9e82d9ab769f3767fb0c38 (patch)
treeb02cd308839398b581964d5b9d0bccd16e431cf8
parentapp-emacs/slime: bump to 2.31 (diff)
downloadgentoo-35ea90bf7fd2e99c9e9e82d9ab769f3767fb0c38.tar.gz
gentoo-35ea90bf7fd2e99c9e9e82d9ab769f3767fb0c38.tar.bz2
gentoo-35ea90bf7fd2e99c9e9e82d9ab769f3767fb0c38.zip
dev-cpp/cpp-httplib: bump to 0.18.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-cpp/cpp-httplib/Manifest1
-rw-r--r--dev-cpp/cpp-httplib/cpp-httplib-0.18.3.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-cpp/cpp-httplib/Manifest b/dev-cpp/cpp-httplib/Manifest
index 3f8ddbaa180b..8aa4db3abf3f 100644
--- a/dev-cpp/cpp-httplib/Manifest
+++ b/dev-cpp/cpp-httplib/Manifest
@@ -1,2 +1,3 @@
DIST cpp-httplib-0.18.0.tar.gz 1321763 BLAKE2B 7807c2f4e3a6a0703a1253f0ec4ac7ef5fbcfad000e517af034a2aff64393229fb47830d215a1959e9893a66f51d19989c33b6b646b79be71e69687fe08cbbf2 SHA512 35ff903d51fee5428d7a95a0406460f8a18d1b5653f6ec8f353d7a2f1084598e599b24d0401f7214d5ee8d9764c74a4e617fff55acd4e6733ab1b9f2d7d4403c
DIST cpp-httplib-0.18.1.tar.gz 1323636 BLAKE2B 8335c9a4d69d7e9b2e7e3c4036b49627536c8d6cffa7a5ae2c3dff693c5458f7fa2f89f3da2c130325069225d3204ec579900d5c5266dff7a9c732c134b39907 SHA512 6dd1054d0171594bf871a918b5540cc67981a48f7dbb82e9029a4877afc6d8c36e2f69411f5eec7b052bf0245554d01f33ef2180f42a15f6b8dd86ebb2427a41
+DIST cpp-httplib-0.18.3.tar.gz 1324253 BLAKE2B 995ae8cd63013ec03e86f56e089b4f1374a8913eaf02d8fc07997b986dc8f65b1bda710ed686b6cc111e6203d15bbcb9db08cd810d2167c1658bfa99dc9b61b2 SHA512 d9eb70dfd8ebde658852d1a8cf9f96419ca11cad889b54672aa4812c0b5db0c3f1fddf63f536aec19fc4a849f41ed22461581a18f0733d3f906e45dd096bafd8
diff --git a/dev-cpp/cpp-httplib/cpp-httplib-0.18.3.ebuild b/dev-cpp/cpp-httplib/cpp-httplib-0.18.3.ebuild
new file mode 100644
index 000000000000..9972ed866068
--- /dev/null
+++ b/dev-cpp/cpp-httplib/cpp-httplib-0.18.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit cmake-multilib python-any-r1 toolchain-funcs
+
+DESCRIPTION="C++ HTTP/HTTPS server and client library"
+HOMEPAGE="https://github.com/yhirose/cpp-httplib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/yhirose/${PN}.git"
+else
+ SRC_URI="https://github.com/yhirose/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}" # soversion / /usr/include/httplib.h: CPPHTTPLIB_VERSION
+
+IUSE="brotli ssl test zlib"
+REQUIRED_USE="test? ( brotli ssl zlib )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ brotli? (
+ app-arch/brotli:=[${MULTILIB_USEDEP}]
+ )
+ ssl? (
+ >=dev-libs/openssl-3.0.13:=[${MULTILIB_USEDEP}]
+ )
+ zlib? (
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DHTTPLIB_COMPILE=yes
+ -DBUILD_SHARED_LIBS=yes
+ -DHTTPLIB_USE_BROTLI_IF_AVAILABLE=no
+ -DHTTPLIB_USE_OPENSSL_IF_AVAILABLE=no
+ -DHTTPLIB_USE_ZLIB_IF_AVAILABLE=no
+ -DHTTPLIB_REQUIRE_BROTLI=$(usex brotli)
+ -DHTTPLIB_REQUIRE_OPENSSL=$(usex ssl)
+ -DHTTPLIB_REQUIRE_ZLIB=$(usex zlib)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ cmake-multilib_src_configure
+}
+
+multilib_src_test() {
+ cp -p -R --reflink=auto "${S}/test" ./test || die
+
+ local -a failing_tests=(
+ # Disable all online tests.
+ "*.*_Online"
+
+ # Fails on musl x86:
+ ServerTest.GetRangeWithMaxLongLength
+ ServerTest.GetStreamedWithTooManyRanges
+
+ # https://github.com/yhirose/cpp-httplib/issues/1798
+ # Filed by mgorny's testing, fails on openssl >=3.2:
+ SSLClientServerTest.ClientCertPresent
+ SSLClientServerTest.ClientEncryptedCertPresent
+ SSLClientServerTest.CustomizeServerSSLCtx
+ SSLClientServerTest.MemoryClientCertPresent
+ SSLClientServerTest.MemoryClientEncryptedCertPresent
+ SSLClientServerTest.TrustDirOptional
+ )
+
+ # Little dance to please the GTEST filter (join array using ":").
+ failing_tests_str="${failing_tests[@]}"
+ failing_tests_filter="${failing_tests_str// /:}"
+
+ # PREFIX is . to avoid calling "brew" and relying on stuff in /opt
+ GTEST_FILTER="-${failing_tests_filter}" emake -C test \
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} -I." PREFIX=.
+}