summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2020-04-25 19:31:10 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-01 15:28:16 +0300
commit3b599ad6587752063fd42e3b9c7fed33771d494e (patch)
tree4e0466db8b8cdc05699db8b481f439b5c5a91793
parentmedia-sound/beets: Add myself and proxy-maint (diff)
downloadgentoo-3b599ad6587752063fd42e3b9c7fed33771d494e.tar.gz
gentoo-3b599ad6587752063fd42e3b9c7fed33771d494e.tar.bz2
gentoo-3b599ad6587752063fd42e3b9c7fed33771d494e.zip
media-sound/beets: cleanup ebuild
Closes: https://bugs.gentoo.org/718398 Bug: https://bugs.gentoo.org/702914 Bug: https://bugs.gentoo.org/693164 Closes: https://bugs.gentoo.org/584276 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-sound/beets/beets-1.4.9-r1.ebuild179
1 files changed, 107 insertions, 72 deletions
diff --git a/media-sound/beets/beets-1.4.9-r1.ebuild b/media-sound/beets/beets-1.4.9-r1.ebuild
index c8b7ae1874fe..8925b67b6761 100644
--- a/media-sound/beets/beets-1.4.9-r1.ebuild
+++ b/media-sound/beets/beets-1.4.9-r1.ebuild
@@ -1,82 +1,101 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_PV=${PV/_beta/-beta.}
-MY_P=${PN}-${MY_PV}
-
-PYTHON_COMPAT=( python3_6 )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
+
+inherit distutils-r1 bash-completion-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/beetbox/beets.git"
+ inherit git-r3
+ KEYWORDS="~amd64 ~x86"
+else
+ MY_PV=${PV/_beta/-beta.}
+ MY_P=${PN}-${MY_PV}
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
DESCRIPTION="Media library management system for obsessive-compulsive music geeks"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
HOMEPAGE="http://beets.io/ https://pypi.org/project/beets/"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
LICENSE="MIT"
+SLOT="0"
IUSE="badfiles chromaprint discogs doc ffmpeg gstreamer icu lastfm mpd replaygain test thumbnail webserver"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
+RDEPEND="${DEPEND}"
DEPEND="
- >=dev-python/jellyfish-0.7.1[${PYTHON_USEDEP}]
- dev-python/munkres[${PYTHON_USEDEP}]
- >=dev-python/python-musicbrainz-ngs-0.4[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
- >=dev-python/six-1.9[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
- >=media-libs/mutagen-1.33[${PYTHON_USEDEP}]
- badfiles? (
- media-libs/flac
- media-sound/mp3val
- )
- chromaprint? (
- dev-python/pyacoustid[${PYTHON_USEDEP}]
- media-libs/chromaprint[tools]
- )
- discogs? ( dev-python/discogs-client[${PYTHON_USEDEP}] )
- ffmpeg? ( media-video/ffmpeg:0[encode] )
- gstreamer? (
- media-libs/gst-plugins-good:1.0
- media-libs/gst-plugins-bad:1.0
- )
- icu? ( dev-db/sqlite[icu] )
- lastfm? ( dev-python/pylast[${PYTHON_USEDEP}] )
- mpd? (
- dev-python/bluelet[${PYTHON_USEDEP}]
- dev-python/python-mpd[${PYTHON_USEDEP}]
- )
- replaygain? (
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/wheel[${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup[${PYTHON_MULTI_USEDEP}]
+ dev-python/flask[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/rarfile[${PYTHON_MULTI_USEDEP}]
+ dev-python/responses[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ )
+ >=dev-python/jellyfish-0.7.1[${PYTHON_MULTI_USEDEP}]
+ dev-python/munkres[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-musicbrainz-ngs-0.4[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/six-1.9[${PYTHON_MULTI_USEDEP}]
+ dev-python/unidecode[${PYTHON_MULTI_USEDEP}]
+ >=media-libs/mutagen-1.33[${PYTHON_MULTI_USEDEP}]
+ badfiles? (
+ media-libs/flac
+ media-sound/mp3val
+ )
+ chromaprint? (
+ dev-python/pyacoustid[${PYTHON_MULTI_USEDEP}]
+ media-libs/chromaprint[tools]
+ )
+ discogs? ( dev-python/discogs-client[${PYTHON_MULTI_USEDEP}] )
+ ffmpeg? ( media-video/ffmpeg:0[encode] )
gstreamer? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- media-plugins/gst-plugins-libav:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-bad:1.0
)
- !gstreamer? ( media-sound/mp3gain )
- )
- thumbnail? (
- dev-python/pyxdg[${PYTHON_USEDEP}]
- || (
- dev-python/pillow[${PYTHON_USEDEP}]
- media-gfx/imagemagick
+ icu? ( dev-db/sqlite[icu] )
+ lastfm? ( dev-python/pylast[${PYTHON_MULTI_USEDEP}] )
+ mpd? (
+ dev-python/bluelet[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpd[${PYTHON_MULTI_USEDEP}]
)
- )
- webserver? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-cors[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${DEPEND}"
+ replaygain? (
+ gstreamer? (
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ media-plugins/gst-plugins-libav:1.0
+ )
+ !gstreamer? ( media-sound/mp3gain )
+ )
+ thumbnail? (
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ || (
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ media-gfx/imagemagick
+ )
+ )
+ webserver? (
+ dev-python/flask[${PYTHON_MULTI_USEDEP}]
+ dev-python/flask-cors[${PYTHON_MULTI_USEDEP}]
+ )
+ ')"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ ')"
-RESTRICT="test" # tests broken in 1.4.3 already
+DOCS=( README.rst docs/changelog.rst )
-S="${WORKDIR}/${MY_P}"
+distutils_enable_tests pytest
python_prepare_all() {
distutils-r1_python_prepare_all
@@ -116,25 +135,41 @@ python_prepare_all() {
if ! use mpd; then
rm test/test_player.py || die
+ rm test/test_mpdstats.py || die
+ fi
+ if ! use webserver; then
+ rm test/test_web.py || die "Failed to remove test_web.py"
+ fi
+ if use test; then
+ # Those test need network
+ rm test/test_art.py || die
+ rm test/test_discogs.py || die
+ rm test/test_embyupdate.py || die
+ rm test/test_lastgenre.py || die
+ rm test/test_spotify.py || die
+ # rm test/test_plexupdate.py
+ rm test/test_thumbnails.py || die
+ # Not working
+ rm test/test_replaygain.py || die
+ # Not working
+ rm test/test_convert.py || die
+ # Not working and dropped in master
+ rm test/test_mediafile.py || die
fi
}
python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cd test || die
- if ! use webserver; then
- rm test_web.py || die "Failed to remove test_web.py"
- fi
- "${EPYTHON}" testall.py || die "Testsuite failed"
+ esetup.py build_sphinx -b man --build-dir=docs/build
+ use doc && esetup.py build_sphinx -b html --build-dir=docs/build
}
python_install_all() {
distutils-r1_python_install_all
- doman man/beet.1 man/beetsconfig.5
- use doc && local HTML_DOCS=( docs/_build/html/. )
+ doman docs/build/man/*
+ use doc && local HTML_DOCS=( docs/build/html/. )
einstalldocs
+
+ "${D}$(python_get_scriptdir)/beet" completion > "${T}/beet.bashcomp"
+ newbashcomp "${T}/beet.bashcomp" beet
}