summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 00:34:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 00:36:04 +0200
commit4e33aa61197053aecccb7c693ac74a44223bc77a (patch)
treedf485d6ae225e513b5cc85f3a4fc12b867662d8a
parentsys-kernel/linux-headers: 5.4-r1: backport alsa time64 fixes (diff)
downloadgentoo-4e33aa61197053aecccb7c693ac74a44223bc77a.tar.gz
gentoo-4e33aa61197053aecccb7c693ac74a44223bc77a.tar.bz2
gentoo-4e33aa61197053aecccb7c693ac74a44223bc77a.zip
media-sound/tomahawk: EAPI-7 bump, use cmake.eclass, build w/ Qt 5.15
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch140
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild13
2 files changed, 148 insertions, 5 deletions
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch
new file mode 100644
index 000000000000..f07b746a03f7
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch
@@ -0,0 +1,140 @@
+From 4fb44c931be648d61ef3c8d10426b34de1b2a53b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 8 May 2020 23:55:43 +0200
+Subject: [PATCH] Fix build with Qt 5.15 (missing QPainterPath)
+
+---
+ src/libtomahawk/utils/AnimatedSpinner.cpp | 1 +
+ src/libtomahawk/utils/TomahawkUtilsGui.cpp | 1 +
+ src/libtomahawk/widgets/DropDownButton.cpp | 2 ++
+ src/libtomahawk/widgets/HoverControls.cpp | 1 +
+ src/libtomahawk/widgets/SourceTreePopupDialog.cpp | 1 +
+ src/libtomahawk/widgets/searchlineedit/SearchButton.cpp | 9 +++++----
+ src/tomahawk/widgets/AccountsPopupWidget.cpp | 1 +
+ src/tomahawk/widgets/SlideSwitchButton.cpp | 1 +
+ src/tomahawk/widgets/SocialWidget.cpp | 3 ++-
+ 9 files changed, 15 insertions(+), 5 deletions(-)
+
+diff --git a/src/libtomahawk/utils/AnimatedSpinner.cpp b/src/libtomahawk/utils/AnimatedSpinner.cpp
+index b4778cbe9..a705cfaa2 100644
+--- a/src/libtomahawk/utils/AnimatedSpinner.cpp
++++ b/src/libtomahawk/utils/AnimatedSpinner.cpp
+@@ -28,6 +28,7 @@
+ #include <QApplication>
+ #include <QHideEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPaintEvent>
+ #include <QShowEvent>
+
+diff --git a/src/libtomahawk/utils/TomahawkUtilsGui.cpp b/src/libtomahawk/utils/TomahawkUtilsGui.cpp
+index b35799723..d2733d4a7 100644
+--- a/src/libtomahawk/utils/TomahawkUtilsGui.cpp
++++ b/src/libtomahawk/utils/TomahawkUtilsGui.cpp
+@@ -32,6 +32,7 @@
+
+ #include <QLayout>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPixmap>
+ #include <QBitmap>
+ #include <QPalette>
+diff --git a/src/libtomahawk/widgets/DropDownButton.cpp b/src/libtomahawk/widgets/DropDownButton.cpp
+index 74aa344d1..106e8b882 100644
+--- a/src/libtomahawk/widgets/DropDownButton.cpp
++++ b/src/libtomahawk/widgets/DropDownButton.cpp
+@@ -19,6 +19,8 @@
+ #include "DropDownButton.h"
+
+ #include <QMouseEvent>
++#include <QPaintEvent>
++#include <QPainterPath>
+
+ #include "Artist.h"
+ #include "Album.h"
+diff --git a/src/libtomahawk/widgets/HoverControls.cpp b/src/libtomahawk/widgets/HoverControls.cpp
+index 3e31bf236..0b6b20aa8 100644
+--- a/src/libtomahawk/widgets/HoverControls.cpp
++++ b/src/libtomahawk/widgets/HoverControls.cpp
+@@ -27,6 +27,7 @@
+ #include <QPixmap>
+ #include <QPaintEvent>
+ #include <QPainter>
++#include <QPainterPath>
+
+ using namespace Tomahawk;
+
+diff --git a/src/libtomahawk/widgets/SourceTreePopupDialog.cpp b/src/libtomahawk/widgets/SourceTreePopupDialog.cpp
+index 807eb354a..1379c9c53 100644
+--- a/src/libtomahawk/widgets/SourceTreePopupDialog.cpp
++++ b/src/libtomahawk/widgets/SourceTreePopupDialog.cpp
+@@ -22,6 +22,7 @@
+ #include <QApplication>
+ #include <QPaintEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QDialogButtonBox>
+ #include <QVBoxLayout>
+ #include <QHBoxLayout>
+diff --git a/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp b/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp
+index 1d9f1c4bd..97c5406f2 100644
+--- a/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp
++++ b/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp
+@@ -19,10 +19,11 @@
+
+ #include "SearchButton.h"
+
+-#include <qcompleter.h>
+-#include <qevent.h>
+-#include <qlineedit.h>
+-#include <qpainter.h>
++#include <QCompleter>
++#include <QEvent>
++#include <QLineEdit>
++#include <QPainter>
++#include <QPainterPath>
+
+ SearchButton::SearchButton(QWidget *parent)
+ : QAbstractButton(parent)
+diff --git a/src/tomahawk/widgets/AccountsPopupWidget.cpp b/src/tomahawk/widgets/AccountsPopupWidget.cpp
+index cb5739b97..ffd5dcaa1 100644
+--- a/src/tomahawk/widgets/AccountsPopupWidget.cpp
++++ b/src/tomahawk/widgets/AccountsPopupWidget.cpp
+@@ -24,6 +24,7 @@
+
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPaintEvent>
+ #include <QVBoxLayout>
+
+diff --git a/src/tomahawk/widgets/SlideSwitchButton.cpp b/src/tomahawk/widgets/SlideSwitchButton.cpp
+index 3c61b4987..103562e00 100644
+--- a/src/tomahawk/widgets/SlideSwitchButton.cpp
++++ b/src/tomahawk/widgets/SlideSwitchButton.cpp
+@@ -24,6 +24,7 @@
+
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPropertyAnimation>
+ #include <QStyleOptionButton>
+ #include <QPixmap>
+diff --git a/src/tomahawk/widgets/SocialWidget.cpp b/src/tomahawk/widgets/SocialWidget.cpp
+index f0901279d..b43f44c5d 100644
+--- a/src/tomahawk/widgets/SocialWidget.cpp
++++ b/src/tomahawk/widgets/SocialWidget.cpp
+@@ -29,8 +29,9 @@
+ #include "Source.h"
+ #include "Track.h"
+
+-#include <QPainter>
+ #include <QDialog>
++#include <QPainter>
++#include <QPainterPath>
+ #include <QPropertyAnimation>
+
+ #define ARROW_HEIGHT 6
+--
+2.26.2
+
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
index fca16414dfb9..e3e201984d00 100644
--- a/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
+++ b/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
COMMIT=777b31219179b43f56c7b95857d2fbd7f33199aa
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Multi-source social music player"
HOMEPAGE="https://github.com/tomahawk-player/tomahawk"
@@ -15,6 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="telepathy xmpp"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
COMMON_DEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -44,7 +47,6 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
dev-qt/designer:5
- dev-qt/linguist-tools:5
dev-qt/qtconcurrent:5
"
RDEPEND="${COMMON_DEPEND}
@@ -56,6 +58,7 @@ S="${WORKDIR}/${PN}-${COMMIT}"
PATCHES=(
"${FILESDIR}/${P}-fix-warning.patch"
"${FILESDIR}/${P}-cmakepolicy.patch" # bug 674826
+ "${FILESDIR}/${P}-qt-5.15.patch" # pending upstream
)
src_configure() {
@@ -70,7 +73,7 @@ src_configure() {
[[ ${PV} != *9999* ]] && mycmakeargs+=( -DBUILD_RELEASE=ON )
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {