summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-13 07:13:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-13 07:30:09 +0200
commit65f830a86a567d2cad3d39732e01d98aef00bbcf (patch)
treec3c8f42d9975d26052be1382c27462d35ba013d8
parentdev-python/google-auth: Bump to 2.6.4 (diff)
downloadgentoo-65f830a86a567d2cad3d39732e01d98aef00bbcf.tar.gz
gentoo-65f830a86a567d2cad3d39732e01d98aef00bbcf.tar.bz2
gentoo-65f830a86a567d2cad3d39732e01d98aef00bbcf.zip
dev-python/PyPDF2: Bump to 1.27.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.27.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 17e66aff6586..04e4c16055f0 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,3 +1,4 @@
DIST PyPDF2-1.26.0.tar.gz 77556 BLAKE2B 8ce9b95165a3841154b6e38e24ca5a4db434ceef9c55fbf2d146b379586160cb985948e0feb7aed135f601535d034ef79ddc1af58a670b07ff7d3621907022ec SHA512 7b427f1d099dcd687a718fb8d86e6f677ad45257414c6367e4dfacd8dfef7e3dbe3816027359868764981f36a30721f1731b4c23cbe2f35cfab1c64fb290b034
DIST PyPDF2-1.27.1.gh.tar.gz 1170252 BLAKE2B 81049707d4dd406405ec994228226edfe7cde4d57007146893c5fec14a4e82355c427cac64a2e338945f06c5bce1802e64bf9b042770a2d2ea7da6ed6982908d SHA512 3bd00e7057af8d0f7fdea378b8fae463ce93d37c68997511df10c53b139c0cb13329143bdac133a825404ab459ab3ead64c455ac3e58ddd5097c2985f86c2a46
DIST PyPDF2-1.27.3.gh.tar.gz 2036376 BLAKE2B fdb35cc61a0fe4c16de9a3717b03c276478a1810ce99996c391d50ccf9ae2d3e048201e95cf9d51e120674aaea2b6435c648ee238d1c9a45de50406c0b3df196 SHA512 01ec6d2f51e6b0865a6d1b5f7cc0297783ee745336b0d8be295c0b1234e1904f2904d49ebbb0f471e65325a75428ed9904f8c565cb7b7001fce27b22521a7f04
+DIST PyPDF2-1.27.4.gh.tar.gz 2037899 BLAKE2B 6f9a71504303959bd8c84d75e0c695e73ffc1927aa664c5ae8b43c678a692ea9c0b1c852d01ace4aa502dc2bba99c7047e373c427a1d044608d0300f5dd647fa SHA512 c0153226e996166ca5f4fa1f04a496afdc5a465dd427df64422748bad907184d18336dbc929b64b479483cf6e435fdeb1dd79d444bc9f4b8cd5f184acb3236f1
diff --git a/dev-python/PyPDF2/PyPDF2-1.27.4.ebuild b/dev-python/PyPDF2/PyPDF2-1.27.4.ebuild
new file mode 100644
index 000000000000..f2b04ef62173
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.27.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}