summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-21 06:36:39 +0300
committerStefan Strogin <steils@gentoo.org>2019-05-21 06:41:07 +0300
commit6953e5c399423d2b4e80e57c4078d52d8d40a6fe (patch)
treebf10c0e9d67b34c74adbe229760579adacc7c053
parentmedia-libs/gst-plugins-bad: arm64 stable (diff)
downloadgentoo-6953e5c399423d2b4e80e57c4078d52d8d40a6fe.tar.gz
gentoo-6953e5c399423d2b4e80e57c4078d52d8d40a6fe.tar.bz2
gentoo-6953e5c399423d2b4e80e57c4078d52d8d40a6fe.zip
net-mail/mailfront: bump version to 2.22
Mask it temporarily since it depends on masked >=dev-libs/bglibs-2.04. Add ~amd64 keyword. Closes: https://bugs.gentoo.org/347479 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-mail/mailfront/Manifest1
-rw-r--r--net-mail/mailfront/mailfront-2.22.ebuild61
-rw-r--r--profiles/package.mask4
3 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/mailfront/Manifest b/net-mail/mailfront/Manifest
index f397135fe098..ab98987d51c9 100644
--- a/net-mail/mailfront/Manifest
+++ b/net-mail/mailfront/Manifest
@@ -1,2 +1,3 @@
DIST mailfront-0.98.tar.gz 77981 BLAKE2B 1729dc60954fa3337bd7be841050886d091fce4a685e928e61c71e70ff30c473f1dfa7e8d59298ef5790cfe165e91c6827c885c423a74cd9cbe5b0bf4dead233 SHA512 ea0e4352219cedad650787dc38ff11d76484cdaef0a4fbd3e51e68f0c0a7676cd591608658ee4f342dfa7e801c67c8a9bd862243fc9b1e776c8b2fe863faf178
DIST mailfront-1.16.tar.gz 108212 BLAKE2B 3b3bd3481b572eb48701a2df71a455838430f615332d7de2d4b3c6beea2a0d3b677cf6907bf975c31e7b2fb6cd60aab5ca45a566c515d2b645553a90391d773a SHA512 7f718e9c3b0f0cb4c5fcae967858f2d3597081c9e8e11c5c5e86f147c3e49e338d20acecccfb83d2db4b7e7a5b33f4cc21b0a0c2f71bb6ab8c71c76189281b2b
+DIST mailfront-2.22.tar.gz 128355 BLAKE2B 593598c353aee9c264690de4af5d472bb4b965cb14aa774a0be6fdece200e078a1e2dbe1feca8135e05a54dad2e0fd3378a4a5903f9a45ccffa260fbbbd2edb6 SHA512 30e1c561f8836bbaf893897b1e864539c44600c4b605d4c8c51c1156c9227967a4ac9e2e9eb0b48bb1827001aff2c6a94e9f44c59bf10e16b5d98595c6a9f2f6
diff --git a/net-mail/mailfront/mailfront-2.22.ebuild b/net-mail/mailfront/mailfront-2.22.ebuild
new file mode 100644
index 000000000000..0fae74cd3b54
--- /dev/null
+++ b/net-mail/mailfront/mailfront-2.22.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Mail server network protocol front-ends"
+HOMEPAGE="https://untroubled.org/mailfront/"
+SRC_URI="https://untroubled.org/mailfront/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-2.04
+ >=net-libs/cvm-0.81"
+RDEPEND="${DEPEND}
+ virtual/qmail
+ net-libs/cvm"
+
+src_configure() {
+ echo "${EPREFIX}/var/qmail" > conf-qmail || die
+ echo "/var/qmail/bin" > conf-bin || die
+ echo "/usr/$(get_libdir)/mailfront" > conf-modules || die
+ echo "/usr/include" > conf-include || die
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} -fPIC -shared" > conf-ccso || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ emake install install_prefix="${ED}"
+ exeinto /var/qmail/supervise/qmail-smtpd
+ newexe "${FILESDIR}"/run-smtpfront run.mailfront
+ exeinto /var/qmail/supervise/qmail-pop3d
+ newexe "${FILESDIR}"/run-pop3front run.mailfront
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
+ docinto html
+ dodoc *.html
+}
+
+pkg_config() {
+ cd "${EROOT}"/var/qmail/supervise/qmail-smtpd/ || die
+ [[ -e run ]] && ( cp run run.qmail-smtpd.`date +%Y%m%d%H%M%S` || die )
+ cp run.mailfront run || die
+
+ cd "${EROOT}"/var/qmail/supervise/qmail-pop3d/ || die
+ [[ -e run ]] && ( cp run run.qmail-pop3d.`date +%Y%m%d%H%M%S` || die )
+ cp run.mailfront run || die
+}
+
+pkg_postinst() {
+ elog "Run"
+ elog "emerge --config '=${CATEGORY}/${PF}'"
+ elog "to update your run files (backups are created) in"
+ elog " /var/qmail/supervise/qmail-pop3d and"
+ elog " /var/qmail/supervise/qmail-smtpd"
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 450f394b454c..04205c39414a 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -29,6 +29,10 @@
#--- END OF EXAMPLES ---
+# Stefan Strogin <steils@gentoo.org> (21 May 2019)
+# Depends on >=dev-libs/bglibs-2.04. Bug #347479.
+>=net-mail/mailfront-2.22
+
# Michał Górny <mgorny@gentoo.org> (19 May 2019)
# Unmaintained. The program breaks init.d script (#626580). Homepage
# and public sources disappeared. Last release in 2006.