summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 09:01:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 12:53:26 +0200
commit6d59b1480ae21df3218eed8c89510d893eb63267 (patch)
tree863cfc3c893bff1b8eab4d5ab7ed571d3e547b6e
parentkde-apps/knotes: 22.04.3 version bump (diff)
downloadgentoo-6d59b1480ae21df3218eed8c89510d893eb63267.tar.gz
gentoo-6d59b1480ae21df3218eed8c89510d893eb63267.tar.bz2
gentoo-6d59b1480ae21df3218eed8c89510d893eb63267.zip
kde-apps/konsolekalendar: 22.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-22.04.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 94d308da7d7e..a5af0991dca2 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-21.12.3.tar.xz 236308 BLAKE2B f72d8e1170071033c4f155272683eb7687dcdeded97ce26e89139c3b74ccd712651a865006c4e986cc68cdd484e5c7cd12cd29dadf090ae37063bc6d18f34c0a SHA512 7e056a1424869ba0f7ed2c57513365225bce183ac62c4da3e434cf561039c34ca9ba034333dc667bcca516f8204439bebe5f69fe14b004f4de907d8809e6d95b
DIST akonadi-calendar-tools-22.04.2.tar.xz 237348 BLAKE2B d11145236ba37f4fa1eaef70667326ccef108311a1d7c1b47f83c77f22b76525eba589e505e0882ea949a929d2f29bb94a0afcd753c171365e9617697c02425e SHA512 53da73f1d43b2ad02c9b61ec121828e908674ba82a85d7f754ac0f5b2ba9fd9637b7c7abf9a01bfb26de18835d1f549e3b3502686ce499fb0c849ce508e015ed
+DIST akonadi-calendar-tools-22.04.3.tar.xz 237900 BLAKE2B 5f9f524a34fc934fcfea44e21584c154770d47408e37140901c14c90527cbb0430fa51d9318711362e572fa8fda710624e076596cb1446e999f978290632ac6b SHA512 781c94f2a4cdd4caec650d74efc0b8c0b2b54fbb5eca7ff6fc22190d7fca600832ac8aa6eb6b62ac3d367916d94a3512cade35b521cb5da19cda69216f06abd0
diff --git a/kde-apps/konsolekalendar/konsolekalendar-22.04.3.ebuild b/kde-apps/konsolekalendar/konsolekalendar-22.04.3.ebuild
new file mode 100644
index 000000000000..869bf87c28bb
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-22.04.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}