summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-21 23:24:30 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-21 23:31:34 +0200
commit7932269ce2c44f097452296f404d8fc57309f403 (patch)
tree7d081c8c62e80f1c3a55f650b8c36595bf9ae308
parentdev-haskell/unexceptionalio: treeclean (diff)
downloadgentoo-7932269ce2c44f097452296f404d8fc57309f403.tar.gz
gentoo-7932269ce2c44f097452296f404d8fc57309f403.tar.bz2
gentoo-7932269ce2c44f097452296f404d8fc57309f403.zip
dev-haskell/top: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-haskell/top/Manifest1
-rw-r--r--dev-haskell/top/files/top-1.7-ghc-7.10.patch66
-rw-r--r--dev-haskell/top/files/top-1.7-ghc84.patch12
-rw-r--r--dev-haskell/top/metadata.xml15
-rw-r--r--dev-haskell/top/top-1.7.ebuild36
-rw-r--r--profiles/package.mask1
6 files changed, 0 insertions, 131 deletions
diff --git a/dev-haskell/top/Manifest b/dev-haskell/top/Manifest
deleted file mode 100644
index 1fc7496525c5..000000000000
--- a/dev-haskell/top/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Top-1.7.tar.gz 70721 BLAKE2B 90ddda99ab4dac209712494c28e15e90ffd2996151ab7df0a57fb8162bec09da6b28fd52b36672e081d10fa0b79d25bb2da2fd58d220573cea006d70c61229f0 SHA512 90d5f1042c07101c35bc1722c18667f551fa4d9034e70a4b7466ff25906899053a054f1227fed8d6d534d04fe9a1c2420585143cde44badfe98e08bf9a6225b4
diff --git a/dev-haskell/top/files/top-1.7-ghc-7.10.patch b/dev-haskell/top/files/top-1.7-ghc-7.10.patch
deleted file mode 100644
index 3acbda19e171..000000000000
--- a/dev-haskell/top/files/top-1.7-ghc-7.10.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-index 2cc5210..faf4c8c 100644
---- a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-+++ b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-@@ -1,2 +1,3 @@
-+{-# LANGUAGE FlexibleContexts #-}
- -----------------------------------------------------------------------------
- -- | License : GPL
-diff --git a/src/Top/Monad/Select.hs b/src/Top/Monad/Select.hs
-index e5953cb..72276b4 100644
---- a/src/Top/Monad/Select.hs
-+++ b/src/Top/Monad/Select.hs
-@@ -16,4 +16,6 @@ module Top.Monad.Select
- import Top.Util.Embedding
- import Control.Monad.State
-+import Control.Monad
-+import Control.Applicative
-
- --------------------------------------------------------
-@@ -22,4 +24,11 @@ import Control.Monad.State
- newtype Select t m a = Select (m a)
-
-+instance Monad m => Functor (Select t m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (Select t m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (Select t m) where
- return a = Select (return a)
-@@ -43,4 +52,11 @@ select = Select
- data SelectFix (t :: (* -> *) -> *) (m :: * -> *) a = SelectFix (m a)
-
-+instance Monad m => Functor (SelectFix t m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (SelectFix t m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (SelectFix t m) where
- return a = SelectFix (return a)
-diff --git a/src/Top/Monad/StateFix.hs b/src/Top/Monad/StateFix.hs
-index d77919d..bd8fb76 100644
---- a/src/Top/Monad/StateFix.hs
-+++ b/src/Top/Monad/StateFix.hs
-@@ -16,4 +16,6 @@ import Control.Monad.State
- import Control.Monad.Identity
- import Control.Monad.Writer
-+import Control.Monad
-+import Control.Applicative
-
- type StateFix s = StateFixT s Identity
-@@ -21,4 +23,11 @@ type StateFix s = StateFixT s Identity
- data StateFixT s m a = Fix { unFix :: StateT (s (StateFixT s m)) m a }
-
-+instance Monad m => Functor (StateFixT s m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (StateFixT s m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (StateFixT s m) where
- return = Fix . return
diff --git a/dev-haskell/top/files/top-1.7-ghc84.patch b/dev-haskell/top/files/top-1.7-ghc84.patch
deleted file mode 100644
index 58ed02d3ff2a..000000000000
--- a/dev-haskell/top/files/top-1.7-ghc84.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/Top/Solver.hs
-+++ b/src/Top/Solver.hs
-@@ -26,2 +26,3 @@ import Top.Constraint.Information
- import Control.Monad.Writer
-+import qualified Data.Semigroup as S
-
-@@ -170,2 +171,5 @@ evalBasicMonad = runWriter . flip evalStateFixT empty
-
-+instance S.Semigroup LogEntries where
-+ (<>) (LogEntries f) (LogEntries g) = LogEntries (f . g)
-+
- instance Monoid LogEntries where
diff --git a/dev-haskell/top/metadata.xml b/dev-haskell/top/metadata.xml
deleted file mode 100644
index 1a045adcfaaf..000000000000
--- a/dev-haskell/top/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- At its most general, Top is a framework for constructing abstract interpretations
- which focuses on giving good feedback on why an abstract interpretation does not give
- any useful information. In a mathematical notation this is usually made explicit by
- returning the top element of a (complete) lattice. This is also one of the reasons
- for the name of the project.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/top/top-1.7.ebuild b/dev-haskell/top/top-1.7.ebuild
deleted file mode 100644
index d6b9761f6b81..000000000000
--- a/dev-haskell/top/top-1.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-MY_PN="Top"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Constraint solving framework employed by the Helium Compiler"
-HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/parsec:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10.1.0
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ghc-7.10.patch
- "${FILESDIR}"/${P}-ghc84.patch
-)
diff --git a/profiles/package.mask b/profiles/package.mask
index 3fb718ca97f8..bc3ddf32aff2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -574,7 +574,6 @@ dev-haskell/text-binary
dev-haskell/text-stream-decode
dev-haskell/th-utilities
dev-haskell/thyme
-dev-haskell/top
# Hans de Graaff <graaff@gentoo.org> (2022-07-16)
# No longer supported upstream. Use a newer ruby version instead.