summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-06 00:14:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-06 01:42:59 +0100
commit7a828416f6d920b96feda9f3370cf210b9fd358f (patch)
tree87eae1d5d37c9f8b70d804815140b7e46a98e74b
parentapp-emacs/gptel: drop old 0.9.5 (diff)
downloadgentoo-7a828416f6d920b96feda9f3370cf210b9fd358f.tar.gz
gentoo-7a828416f6d920b96feda9f3370cf210b9fd358f.tar.bz2
gentoo-7a828416f6d920b96feda9f3370cf210b9fd358f.zip
app-emacs/gptel: bump to 0.9.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/gptel/Manifest1
-rw-r--r--app-emacs/gptel/gptel-0.9.7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/gptel/Manifest b/app-emacs/gptel/Manifest
index ceb1e6a3ca3e..6dba8fd8ccd7 100644
--- a/app-emacs/gptel/Manifest
+++ b/app-emacs/gptel/Manifest
@@ -1 +1,2 @@
DIST gptel-0.9.6.tar.gz 92734 BLAKE2B 52e7f79594e63128178c3a988e7fb0c60421b1a3da6bb6e47fe64fec176134e8af6d43b9504e55bc9f19bc03635d10a5ad0ab6fb4103dfaab0a4de730aaa43c6 SHA512 e7c1d7599d0ee68ecf61763bbc0580df67f22d4a9d77c535827f5b02b7fb45efb5d163cc0fc3cd1ef78fbbc246dc518488c28debf88322199bab1f5fd760efb9
+DIST gptel-0.9.7.tar.gz 99088 BLAKE2B ccf5d8fade5cf41d6cead4c6b48f0e6ad2672187cfd6b392a549bbd24024b85d3a317ab923b7cc9203610ec1a045709e92d18e7f1ef0b48d9709c9fcdbf02396 SHA512 db20af896255e5fb6c05ee6dc8465bf26638946778c6c05026361193837f8cfa49220622194f92ef827cd7e691ea61c4b87a030455014ac3e7d0ca211be8cf33
diff --git a/app-emacs/gptel/gptel-0.9.7.ebuild b/app-emacs/gptel/gptel-0.9.7.ebuild
new file mode 100644
index 000000000000..f1f82c0c216f
--- /dev/null
+++ b/app-emacs/gptel/gptel-0.9.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Simple Large Language Model chat client for GNU Emacs"
+HOMEPAGE="https://github.com/karthink/gptel/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/karthink/${PN}.git"
+else
+ SRC_URI="https://github.com/karthink/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ app-emacs/transient
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}