summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-09 05:55:46 +0000
committerSam James <sam@gentoo.org>2023-03-09 05:58:29 +0000
commit7becac16ac0f3ea841f36b2465dd8cb2c427a9d2 (patch)
treed7b762f04d432bff29fb21a4163190a66160fd7f
parentapp-forensics/afflib: update upstream metadata (diff)
downloadgentoo-7becac16ac0f3ea841f36b2465dd8cb2c427a9d2.tar.gz
gentoo-7becac16ac0f3ea841f36b2465dd8cb2c427a9d2.tar.bz2
gentoo-7becac16ac0f3ea841f36b2465dd8cb2c427a9d2.zip
app-forensics/afflib: add 3.7.20
Closes: https://bugs.gentoo.org/896542 Closes: https://bugs.gentoo.org/893002 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-forensics/afflib/Manifest1
-rw-r--r--app-forensics/afflib/afflib-3.7.20.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-forensics/afflib/Manifest b/app-forensics/afflib/Manifest
index 76fd811dba8d..b00e6dbceb28 100644
--- a/app-forensics/afflib/Manifest
+++ b/app-forensics/afflib/Manifest
@@ -1 +1,2 @@
DIST afflib-3.7.19.tar.gz 540165 BLAKE2B dea0998741121d2c1ae0e42ced9652ec46816282128469af75e0a32f9e4e2d09ac4afb4888ee7925366a03a867932f2446bfcd3800ab4dc021939ab6c38c797b SHA512 6e0df7477bf7dbd3814099d94e3fce122e0cf9b714a425521b7458f4eedc6e8b8e7283fd37926b7c992cdf21d3adec620df29a79a6a5311bf1d1b5d4930768bc
+DIST afflib-3.7.20.tar.gz 560441 BLAKE2B 6934efc30566b4b72e55e5727c46657362237872acae9d161f2625439d3d6e12da702b3ed82e3442b7015d8cb707097152cc73a6d0cc31d1ad61467f4022f7d4 SHA512 1ac623cb8462fc929a8ad1c014e92d319a3ebf5226ef07aa0777e4cbb77a9ee20adf570f39c960c9186ac2a477e861dfd5565d3364fdff22f9870f8c9ab30479
diff --git a/app-forensics/afflib/afflib-3.7.20.ebuild b/app-forensics/afflib/afflib-3.7.20.ebuild
new file mode 100644
index 000000000000..7a9a46d498cf
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.7.20.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1
+
+MY_PN=AFFLIBv3
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="https://github.com/sshock/AFFLIBv3/"
+SRC_URI="https://github.com/sshock/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~x64-macos"
+IUSE="fuse ncurses python qemu readline s3 static-libs threads"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+# Tests don't play well with sandbox
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/expat
+ sys-libs/zlib:=
+ fuse? ( sys-fs/fuse:0 )
+ dev-libs/openssl:=
+ ncurses? ( sys-libs/ncurses:= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]')
+ )
+ readline? ( sys-libs/readline:= )
+ s3? ( net-misc/curl )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.7.19-search-path.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/FLAGS/s: -g::' \
+ -e 's:-D_FORTIFY_SOURCE=2::' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable static-libs static)
+ $(use_enable threads threading)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete || die
+}