summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-08 18:41:45 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-08 19:05:41 -0700
commit7cd132b7f4b0b6fd53cea357458f0afd6d2ce306 (patch)
tree2e8aeb61e3a9c095dde0cc7f87d0c7248a8c78f7
parentdev-python/python-libevdev: Add package (diff)
downloadgentoo-7cd132b7f4b0b6fd53cea357458f0afd6d2ce306.tar.gz
gentoo-7cd132b7f4b0b6fd53cea357458f0afd6d2ce306.tar.bz2
gentoo-7cd132b7f4b0b6fd53cea357458f0afd6d2ce306.zip
dev-libs/libinput: Unrestrict tests
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/libinput/libinput-1.15.3.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-libs/libinput/libinput-1.15.3.ebuild b/dev-libs/libinput/libinput-1.15.3.ebuild
index 313a4e3d067c..43de3f8241a4 100644
--- a/dev-libs/libinput/libinput-1.15.3.ebuild
+++ b/dev-libs/libinput/libinput-1.15.3.ebuild
@@ -14,10 +14,8 @@ LICENSE="MIT"
SLOT="0/10"
[[ "$(ver_cut 3)" -gt 900 ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc input_devices_wacom"
-# Tests require write access to udev rules directory which is a no-no for live system.
-# Other tests are just about logs, exported symbols and autotest of the test library.
-RESTRICT="test"
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
BDEPEND="
virtual/pkgconfig
@@ -40,8 +38,8 @@ RDEPEND="
virtual/libudev:=
virtual/udev
"
-DEPEND="${RDEPEND}"
-# test? ( >=dev-libs/check-0.9.10 )
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )"
python_check_deps() {
has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
@@ -60,7 +58,7 @@ src_configure() {
-Ddebug-gui=false
$(meson_use doc documentation)
$(meson_use input_devices_wacom libwacom)
- -Dtests=false # tests are restricted
+ $(meson_use test tests)
-Dudev-dir="${EPREFIX}$(get_udevdir)"
)
meson_src_configure