summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-18 22:38:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-18 23:28:30 +0100
commit7eea3abc0f7222984748545af12baa7b618c47f5 (patch)
tree0383078d490699ca55799dcf55ed7d404cff7142
parentdev-python/botocore: Bump to 1.23.9 (diff)
downloadgentoo-7eea3abc0f7222984748545af12baa7b618c47f5.tar.gz
gentoo-7eea3abc0f7222984748545af12baa7b618c47f5.tar.bz2
gentoo-7eea3abc0f7222984748545af12baa7b618c47f5.zip
dev-python/boto3: Bump to 1.20.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.9.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 16874eed0c1f..f96d08f2755a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5
DIST boto3-1.20.6.tar.gz 440133 BLAKE2B b154714261372cebb8643d529b66fe3a42d30e056cf2a454092d598c51d0cdef723980834be6a36abb892d3022ae8ef67053b22bb176f540e67c3f37422155d8 SHA512 d8d66a761f03beeca10fea8446de1136d418a93b21065aebfefcafe2abfd9b5bbfa243594f54647ad80547e48348086e2be2de129b89f9ca71f308579f11a0b7
DIST boto3-1.20.7.tar.gz 440428 BLAKE2B f1b2b36799e6c22a40c04226443f15f9174d68a02d2f731df84f6ff0962158e9d940ae5bc04d25fe99a74f105946026ccb66547838734294d649d661071c1e3b SHA512 85493a85789caa5453a4dafa1472c8ecd75c05a819227909092ae03690243eb103c1588cb10e5e5277ab9df49673b9b54fda064a412bdcf6b9e11238b277f450
DIST boto3-1.20.8.tar.gz 441260 BLAKE2B 9a9e6620fecbcbb4cd28c7ed8d1c6a42c5325e8c44529fa1855c30e3b3a20ab5963e533cfbda1877204075ac2917e8bf3335fa56dcc146813554a33b52bc80af SHA512 6223def67826aaf98dbf5102755f2e6204558534fbbc34552e411ce64ebba4bd03d01f984246ee7c70d06fb5a19313a4da041aa31b33e75867d0591973037009
+DIST boto3-1.20.9.tar.gz 443171 BLAKE2B be0300a416ba0542b79e97db9fcd4d65cdef5acd8234943316125fe2b24135dd26212f2b2dcff867a8981b56bfb61ac1a6d63985f6c76b8f967d40917e07ede8 SHA512 a6a7cb7a64b7bc652aab80dbe47471fa94f1d24dfc39ef0c774aa0ab10dcfd196ccceee29c1b5149f9b70f54888e600f5769a5a481bb1195039ced3efc68e883
diff --git a/dev-python/boto3/boto3-1.20.9.ebuild b/dev-python/boto3/boto3-1.20.9.ebuild
new file mode 100644
index 000000000000..a4f6b1d0f3c2
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}