summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-18 15:28:56 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-18 15:32:22 +0200
commit81a7a20fb3c4d6262f0ff6c9f5e47e3c1ac41ebb (patch)
treeb068819f9c4ebf3ad08c51b12f291f8fc17bd1a5
parentx32/package.mask: add reverse dep of coffeescript (diff)
downloadgentoo-81a7a20fb3c4d6262f0ff6c9f5e47e3c1ac41ebb.tar.gz
gentoo-81a7a20fb3c4d6262f0ff6c9f5e47e3c1ac41ebb.tar.bz2
gentoo-81a7a20fb3c4d6262f0ff6c9f5e47e3c1ac41ebb.zip
dev-ruby/bundler: drop default for doc USE flag
Starting with bundler 2.2.0 the internal help pages are now bundled and don't require the doc USE flag to create. This removes the need to make it a default USE flag. This should make upgrading with standard USE flags much easier. Closes: https://bugs.gentoo.org/704164 Closes: https://bugs.gentoo.org/849695 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/bundler/bundler-2.2.33-r1.ebuild30
-rw-r--r--dev-ruby/bundler/bundler-2.3.8-r1.ebuild30
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/bundler/bundler-2.2.33-r1.ebuild b/dev-ruby/bundler/bundler-2.2.33-r1.ebuild
new file mode 100644
index 000000000000..9d50b60b14f3
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.2.33-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git !<dev-ruby/bundler-1.17.3-r1:0"
diff --git a/dev-ruby/bundler/bundler-2.3.8-r1.ebuild b/dev-ruby/bundler/bundler-2.3.8-r1.ebuild
new file mode 100644
index 000000000000..dea6a7a8a97c
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.3.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git !<dev-ruby/bundler-1.17.3-r1:0"