summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 06:21:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 06:40:15 +0100
commit821cb77b32c8db8d33617886276cbabd5bae0673 (patch)
treeff8cf36adbca968602f3a6e7c2a6267767fc033e
parentdev-python/mkdocs-material: Bump to 9.5.45 (diff)
downloadgentoo-821cb77b32c8db8d33617886276cbabd5bae0673.tar.gz
gentoo-821cb77b32c8db8d33617886276cbabd5bae0673.tar.bz2
gentoo-821cb77b32c8db8d33617886276cbabd5bae0673.zip
dev-python/stripe: Bump to 11.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/stripe/Manifest1
-rw-r--r--dev-python/stripe/stripe-11.3.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
index 2281a07f63e4..f9ca115e9ef7 100644
--- a/dev-python/stripe/Manifest
+++ b/dev-python/stripe/Manifest
@@ -1 +1,2 @@
DIST stripe-11.2.0.tar.gz 1362386 BLAKE2B 56e22671886efe3e2b8d3c7f41402f5dcf4320e3ceea8d0ed9cf2813ba682ead62e9af796ef94d05f5eb18f678c55c36a1005902fdceca5ce9a9b5b4ac204193 SHA512 9344845d6b9b89886ea6ec2918b4ce53545141232aadaadfbf3f7bdd6522b1ee1bfe57f0145e69c0edeb66fb01dedb3a9fd7263410f7d2fbae7240c68ac87936
+DIST stripe-11.3.0.tar.gz 1367031 BLAKE2B b46cae95059a1aa7087743772b5cb23456e64b276befa852b0c13ce417f624ac6d9a90e64a43aeb3d60941ad73cc87afa114d4161c5e5b3e5ae6033b4378f6c1 SHA512 4b8934653f138b86f7d64977f2817fc0ad54a89d794521af7d1f193ecdcbb366e78ece286a3c768f946d281aba998443e675e6db66fcd3a0084641053e55a182
diff --git a/dev-python/stripe/stripe-11.3.0.ebuild b/dev-python/stripe/stripe-11.3.0.ebuild
new file mode 100644
index 000000000000..eb697bfc26cb
--- /dev/null
+++ b/dev-python/stripe/stripe-11.3.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stripe Python bindings"
+HOMEPAGE="
+ https://github.com/stripe/stripe-python/
+ https://pypi.org/project/stripe/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="telemetry"
+
+RDEPEND="
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
+"
+# please bump dev-util/stripe-mock dep to the latest version on every bump
+BDEPEND="
+ test? (
+ >=dev-util/stripe-mock-0.192.0
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ net-misc/curl
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+DOCS=( LONG_DESCRIPTION.rst CHANGELOG.md README.md )
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ if ! use telemetry; then
+ sed -i -e '/enable_telemetry/s:True:False:' stripe/__init__.py || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # exception message mismatch with aiohttp-3.10.0
+ "tests/test_integration.py::TestIntegration::test_async_timeout[asyncio-aiohttp]"
+ "tests/test_integration.py::TestIntegration::test_async_raw_request_timeout[asyncio-aiohttp]"
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests -p anyio -p pytest_mock
+}
+
+src_test() {
+ local stripe_mock_port=12111
+ local stripe_mock_max_port=12121
+ local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
+ # Try to start stripe-mock until we find a free port
+ while [[ ${stripe_mock_port} -le ${stripe_mock_max_port} ]]; do
+ ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
+ stripe-mock --http-port "${stripe_mock_port}" &> "${stripe_mock_logfile}" &
+ local stripe_mock_pid=${!}
+ sleep 2
+ # Did stripe-mock start?
+ curl --fail -u "sk_test_123:" \
+ "http://127.0.0.1:${stripe_mock_port}/v1/customers" &> /dev/null
+ eend ${?} "Port ${stripe_mock_port} unavailable"
+ if [[ ${?} -eq 0 ]]; then
+ einfo "stripe-mock running on port ${stripe_mock_port}"
+ break
+ fi
+ (( stripe_mock_port++ ))
+ done
+ if [[ ${stripe_mock_port} -gt ${stripe_mock_max_port} ]]; then
+ eerror "Unable to start stripe-mock for tests"
+ die "Please see the logfile located at: ${stripe_mock_logfile}"
+ fi
+
+ local -x STRIPE_MOCK_PORT=${stripe_mock_port}
+ distutils-r1_src_test
+
+ # Tear down stripe-mock
+ kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
+}