summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:31:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 11:09:36 +0100
commit8757085ff45841a5801ef65faa258bb2866233d8 (patch)
treef1892d691daa00dac9e4a11b570f96b2e4218ae0
parentprofiles: Unmask app-text/poppler-0.84.0 (diff)
downloadgentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.gz
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.bz2
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.zip
*/*: Switch polynomial-c maintained packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild6
-rw-r--r--app-admin/keepassxc/keepassxc-2.5.0.ebuild6
-rw-r--r--app-admin/keepassxc/keepassxc-2.5.1.ebuild6
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild6
-rw-r--r--app-shells/fish/fish-3.0.2.ebuild11
-rw-r--r--app-shells/fish/fish-9999.ebuild11
-rw-r--r--dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild10
-rw-r--r--games-emulation/mgba/mgba-0.7.3.ebuild8
-rw-r--r--games-emulation/mgba/mgba-0.8_beta1.ebuild8
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild8
-rw-r--r--games-engines/devilutionx/devilutionx-9999.ebuild4
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20190127.ebuild6
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20190609.ebuild6
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20191004.ebuild6
-rw-r--r--media-sound/clementine/clementine-9999.ebuild6
-rw-r--r--media-sound/lmms/lmms-1.2.0.ebuild8
-rw-r--r--media-sound/lmms/lmms-1.2.1.ebuild8
-rw-r--r--media-sound/lmms/lmms-9999.ebuild8
-rw-r--r--media-sound/pamix/pamix-9999.ebuild4
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.3.11-r2.ebuild7
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild7
-rw-r--r--sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild10
-rw-r--r--sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.8.ebuild6
-rw-r--r--sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.9.ebuild6
-rw-r--r--sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild6
25 files changed, 89 insertions, 89 deletions
diff --git a/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild b/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild
index 914683fba0df..83eb419c1194 100644
--- a/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.4.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -66,7 +66,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -84,7 +84,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-admin/keepassxc/keepassxc-2.5.0.ebuild b/app-admin/keepassxc/keepassxc-2.5.0.ebuild
index 75059bb064ab..344be63f0741 100644
--- a/app-admin/keepassxc/keepassxc-2.5.0.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -67,7 +67,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-admin/keepassxc/keepassxc-2.5.1.ebuild b/app-admin/keepassxc/keepassxc-2.5.1.ebuild
index 75059bb064ab..344be63f0741 100644
--- a/app-admin/keepassxc/keepassxc-2.5.1.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.5.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -67,7 +67,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 75059bb064ab..344be63f0741 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
@@ -67,7 +67,7 @@ src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/app-shells/fish/fish-3.0.2.ebuild b/app-shells/fish/fish-3.0.2.ebuild
index 540ec26c1feb..3a16d56f7c07 100644
--- a/app-shells/fish/fish-3.0.2.ebuild
+++ b/app-shells/fish/fish-3.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"
@@ -45,30 +45,29 @@ src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
cmake/Tests.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DCURSES_NEED_NCURSES=ON
-DINTERNAL_WCWIDTH=OFF
-DBUILD_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
readme.gentoo_create_doc
}
src_test() {
- cmake-utils_src_make -j1 test
+ cmake_build -j1 test
}
pkg_postinst() {
diff --git a/app-shells/fish/fish-9999.ebuild b/app-shells/fish/fish-9999.ebuild
index cf5816108b09..e718e3cbc309 100644
--- a/app-shells/fish/fish-9999.ebuild
+++ b/app-shells/fish/fish-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"
@@ -42,30 +42,29 @@ src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
cmake/Tests.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DCURSES_NEED_NCURSES=ON
-DINTERNAL_WCWIDTH=OFF
-DBUILD_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
readme.gentoo_create_doc
}
src_test() {
- cmake-utils_src_make -j1 test
+ cmake_build -j1 test
}
pkg_postinst() {
diff --git a/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild b/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild
index 5a1347b66e79..40164dbc61bf 100644
--- a/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild
+++ b/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Provides functionality for gaming input devices"
@@ -39,9 +39,9 @@ PATCHES=(
"${FILESDIR}"/${P}-cmake-3.13.patch
)
-# Required because xdg.eclass overrides src_prepare() from cmake-utils.eclass
+# Required because xdg.eclass overrides src_prepare() from cmake.eclass
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -49,11 +49,11 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
-DWITH_DOC="$(usex doc)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
}
pkg_preinst() {
diff --git a/games-emulation/mgba/mgba-0.7.3.ebuild b/games-emulation/mgba/mgba-0.7.3.ebuild
index 013c485228bf..759399b0d4b9 100644
--- a/games-emulation/mgba/mgba-0.7.3.ebuild
+++ b/games-emulation/mgba/mgba-0.7.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
@@ -44,7 +44,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
@@ -79,11 +79,11 @@ src_configure() {
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
diff --git a/games-emulation/mgba/mgba-0.8_beta1.ebuild b/games-emulation/mgba/mgba-0.8_beta1.ebuild
index 014fe2c0a7ce..035f986d3021 100644
--- a/games-emulation/mgba/mgba-0.8_beta1.ebuild
+++ b/games-emulation/mgba/mgba-0.8_beta1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
@@ -82,11 +82,11 @@ src_configure() {
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index 014fe2c0a7ce..035f986d3021 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
@@ -82,11 +82,11 @@ src_configure() {
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
diff --git a/games-engines/devilutionx/devilutionx-9999.ebuild b/games-engines/devilutionx/devilutionx-9999.ebuild
index d191d5e65931..c0684055693c 100644
--- a/games-engines/devilutionx/devilutionx-9999.ebuild
+++ b/games-engines/devilutionx/devilutionx-9999.ebuild
@@ -9,7 +9,7 @@ EAPI=7
# https://github.com/diasurgical/devilutionX/issues/490
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils desktop
+inherit cmake desktop
DESCRIPTION="Diablo engine for modern operating systems"
HOMEPAGE="https://github.com/diasurgical/devilutionX"
@@ -42,7 +42,7 @@ src_configure() {
-DBINARY_RELEASE=ON
-DDEBUG="$(usex debug)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
diff --git a/media-sound/clementine/clementine-1.3.1_p20190127.ebuild b/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
index 9aa4ffa1983b..a2bb0b39fd2e 100644
--- a/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
@@ -15,7 +15,7 @@ else
SRC_URI="https://github.com/${PN}-player/${PN^}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 x86"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -108,7 +108,7 @@ DOCS=( Changelog README.md )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -158,7 +158,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/clementine/clementine-1.3.1_p20190609.ebuild b/media-sound/clementine/clementine-1.3.1_p20190609.ebuild
index c1abcfd676e4..3e212f782448 100644
--- a/media-sound/clementine/clementine-1.3.1_p20190609.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20190609.ebuild
@@ -16,7 +16,7 @@ else
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN^}-${COMMIT}"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -109,7 +109,7 @@ PATCHES=( "${FILESDIR}/${P}-fix-restore-from-systray.patch" )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -159,7 +159,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/clementine/clementine-1.3.1_p20191004.ebuild b/media-sound/clementine/clementine-1.3.1_p20191004.ebuild
index f2d1766fb153..4e52840045fa 100644
--- a/media-sound/clementine/clementine-1.3.1_p20191004.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20191004.ebuild
@@ -16,7 +16,7 @@ else
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN^}-${COMMIT}"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -101,7 +101,7 @@ DOCS=( Changelog README.md )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -151,7 +151,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index 3efe963fe1b3..be99d91ad509 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -14,7 +14,7 @@ else
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN^}-${COMMIT}"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -98,7 +98,7 @@ DOCS=( Changelog README.md )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -148,7 +148,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/lmms/lmms-1.2.0.ebuild b/media-sound/lmms/lmms-1.2.0.ebuild
index d5f82bfff2a3..e489666c90fe 100644
--- a/media-sound/lmms/lmms-1.2.0.ebuild
+++ b/media-sound/lmms/lmms-1.2.0.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-# The order is important here! Both, cmake-utils and xdg define src_prepare.
-# We need the one from cmake-utils
-inherit xdg cmake-utils
+# The order is important here! Both, cmake and xdg define src_prepare.
+# We need the one from cmake
+inherit xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -90,7 +90,7 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-sound/lmms/lmms-1.2.1.ebuild b/media-sound/lmms/lmms-1.2.1.ebuild
index d5f82bfff2a3..e489666c90fe 100644
--- a/media-sound/lmms/lmms-1.2.1.ebuild
+++ b/media-sound/lmms/lmms-1.2.1.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-# The order is important here! Both, cmake-utils and xdg define src_prepare.
-# We need the one from cmake-utils
-inherit xdg cmake-utils
+# The order is important here! Both, cmake and xdg define src_prepare.
+# We need the one from cmake
+inherit xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -90,7 +90,7 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index 66d6fbe1e437..376874f97b14 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-# The order is important here! Both, cmake-utils and xdg define src_prepare.
-# We need the one from cmake-utils
-inherit xdg cmake-utils
+# The order is important here! Both, cmake and xdg define src_prepare.
+# We need the one from cmake
+inherit xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -90,7 +90,7 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
index b4f4397507df..1e8fad344924 100644
--- a/media-sound/pamix/pamix-9999.ebuild
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ "${PV}" == 9999 ]] ; then
inherit git-r3
@@ -34,5 +34,5 @@ src_configure() {
local mycmakeargs=(
-DWITH_UNICODE="$(usex unicode)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.3.11-r2.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.11-r2.ebuild
index ebea68fc269a..54eeceee53ad 100644
--- a/media-video/simplescreenrecorder/simplescreenrecorder-0.3.11-r2.ebuild
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.11-r2.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib flag-o-matic xdg
if [[ ${PV} = 9999 ]]; then
@@ -73,8 +74,8 @@ pkg_setup() {
}
src_prepare() {
- # required because xdg.eclass overrides default cmake-utils_src_prepare
- cmake-utils_src_prepare
+ # required because xdg.eclass overrides default cmake_src_prepare
+ cmake_src_prepare
}
multilib_src_configure() {
@@ -105,7 +106,7 @@ multilib_src_configure() {
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
index ebea68fc269a..54eeceee53ad 100644
--- a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib flag-o-matic xdg
if [[ ${PV} = 9999 ]]; then
@@ -73,8 +74,8 @@ pkg_setup() {
}
src_prepare() {
- # required because xdg.eclass overrides default cmake-utils_src_prepare
- cmake-utils_src_prepare
+ # required because xdg.eclass overrides default cmake_src_prepare
+ cmake_src_prepare
}
multilib_src_configure() {
@@ -105,7 +106,7 @@ multilib_src_configure() {
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild b/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
index db2565cfe822..9be7384e3244 100644
--- a/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
+++ b/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit readme.gentoo-r1 cmake-utils udev user xdg
+inherit readme.gentoo-r1 cmake udev user xdg
DESCRIPTION="Utility for advanced configuration of Roccat devices"
@@ -74,9 +74,9 @@ pkg_setup() {
done
}
-# Required because xdg.eclass overrides src_prepare() from cmake-utils.eclass
+# Required because xdg.eclass overrides src_prepare() from cmake.eclass
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -98,11 +98,11 @@ src_configure() {
fi
done
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local stat_dir=/var/lib/roccat
keepdir ${stat_dir}
fowners root:roccat ${stat_dir}
diff --git a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.8.ebuild b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.8.ebuild
index dbd8f4ce067c..96cfef233539 100644
--- a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.8.ebuild
+++ b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Android File Transfer for Linux"
HOMEPAGE="https://github.com/whoozle/android-file-transfer-linux"
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}"
# required to override src_prepare from xdg eclass
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -48,7 +48,7 @@ src_configure() {
-DUSB_BACKEND_LIBUSB="OFF"
$(usex qt5 '-DDESIRED_QT_VERSION=5' '')
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.9.ebuild b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.9.ebuild
index 08a6fef6fea6..e2ce2ae66cfe 100644
--- a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.9.ebuild
+++ b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-3.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Android File Transfer for Linux"
HOMEPAGE="https://github.com/whoozle/android-file-transfer-linux"
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}"
# required to override src_prepare from xdg eclass
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -48,7 +48,7 @@ src_configure() {
-DUSB_BACKEND_LIBUSB="OFF"
$(usex qt5 '-DDESIRED_QT_VERSION=5' '')
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
index dbd8f4ce067c..96cfef233539 100644
--- a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
+++ b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Android File Transfer for Linux"
HOMEPAGE="https://github.com/whoozle/android-file-transfer-linux"
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}"
# required to override src_prepare from xdg eclass
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -48,7 +48,7 @@ src_configure() {
-DUSB_BACKEND_LIBUSB="OFF"
$(usex qt5 '-DDESIRED_QT_VERSION=5' '')
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {