summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-07 17:47:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-07 18:25:08 +0100
commit8bf8fa13e0378117f27195c370fa734f5cd7f520 (patch)
tree5a6bb45738842e6dd307e32167977afa0e2f2ed1
parentgames-server/pvpgn: drop 1.8.5-r4 (diff)
downloadgentoo-8bf8fa13e0378117f27195c370fa734f5cd7f520.tar.gz
gentoo-8bf8fa13e0378117f27195c370fa734f5cd7f520.tar.bz2
gentoo-8bf8fa13e0378117f27195c370fa734f5cd7f520.zip
net-misc/grive: drop versions
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-misc/grive/Manifest2
-rw-r--r--net-misc/grive/files/299.patch113
-rw-r--r--net-misc/grive/grive-0.5.1-r1.ebuild36
-rw-r--r--net-misc/grive/grive-0.5.2_pre20200205.ebuild35
-rw-r--r--net-misc/grive/grive-0.5.2_pre20211128.ebuild35
5 files changed, 0 insertions, 221 deletions
diff --git a/net-misc/grive/Manifest b/net-misc/grive/Manifest
index 493ad439d60f..32c918f3481c 100644
--- a/net-misc/grive/Manifest
+++ b/net-misc/grive/Manifest
@@ -1,3 +1 @@
-DIST grive-0.5.1.tar.gz 169929 BLAKE2B a8f8fc9f3bcf019b7b713178f6a39ca6c62f6531054329d4ff8ac6fbfdfa5579f9e51aa8f9c493b90005194c3ab77934575e541c0986404a32e807c5c87c4cfd SHA512 609837fc93ad78d143dcb4d1f558743d413c887fec2e9aaac81edd58549b812db859aab5ce7f664f06564779cff4bae32d43529e47fcc36640f1a9b52c5b5888
-DIST grive-0.5.2_pre20200205.tar.gz 170384 BLAKE2B dac8d75bdefe0c206f443010093e73b34ae8257a5ced87917cca240fb7134a6aac8e5f018eeb7bf7dec46d5043e144efb2c9586ca2b5ff55a1d0fe022f72675a SHA512 d1058649d2a3dce773eab53b1704c5dd8bb1998089099ed9c3bacdaa5d3f995fa08c1b2c2b723bbce0efa2c9c04729d97aade6df6130da32f975e2bb45f339e6
DIST grive-0.5.2_pre20211128.tar.gz 171412 BLAKE2B 62e966917959ed4306a7a787948bc1533cca6a5521f262450658c81f6dc88cb7914df6c3a8271d87fdc189ff74ada421f76c38bd9b89157cd27ef0f2ba531e67 SHA512 33e6a382f979a0a7a6c4236bce1779bbda0b3817b7d2f1750f6759350d7de79bd999bd0f4f7cb72fd32586683053ef1d21dc830403a9d1225b6e9a3408f830fa
diff --git a/net-misc/grive/files/299.patch b/net-misc/grive/files/299.patch
deleted file mode 100644
index a5e030f2534a..000000000000
--- a/net-misc/grive/files/299.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-From b4d6ac055f8f16ac735a70036243bc4ea2334039 Mon Sep 17 00:00:00 2001
-From: Giuseppe Corbelli <corbelligiuseppe@mesdan.it>
-Date: Tue, 14 Jan 2020 11:50:20 +0100
-Subject: [PATCH] [SymbolInfo.cc] Support compilation with binutils >= 2.33.1
- on Debian.
-
-bfd_get_section_vma macro was removed.
-bfd_section_size changed signature.
-
-See inline comment for details.
----
- libgrive/src/bfd/SymbolInfo.cc | 35 ++++++++++++++++++++--------------
- 1 file changed, 21 insertions(+), 14 deletions(-)
-
-diff --git a/libgrive/src/bfd/SymbolInfo.cc b/libgrive/src/bfd/SymbolInfo.cc
-index 5876cc0..cdb5d7c 100644
---- a/libgrive/src/bfd/SymbolInfo.cc
-+++ b/libgrive/src/bfd/SymbolInfo.cc
-@@ -49,9 +49,9 @@ SymbolInfo::SymbolInfo( )
- m_impl->m_bfd = 0 ;
- m_impl->m_symbols = 0 ;
- m_impl->m_symbol_count = 0 ;
--
-+
- bfd_init( ) ;
--
-+
- // opening itself
- bfd *b = bfd_openr( "/proc/self/exe", 0 ) ;
- if ( b == NULL )
-@@ -60,13 +60,13 @@ SymbolInfo::SymbolInfo( )
- << bfd_errmsg( bfd_get_error() ) << std::endl ;
- return ;
- }
--
-+
- if ( bfd_check_format( b, bfd_archive ) )
- {
- bfd_close( b ) ;
- return ;
- }
--
-+
- char **matching ;
- if ( !bfd_check_format_matches( b, bfd_object, &matching ) )
- {
-@@ -78,7 +78,7 @@ SymbolInfo::SymbolInfo( )
- std::cerr << bfd_get_filename( b ) << ": Matching formats: " ;
- for ( char **p = matching ; *p != 0 ; p++ )
- std::cerr << " " << *p ;
--
-+
- std::cerr << std::endl ;
- std::free( matching ) ;
- }
-@@ -107,7 +107,7 @@ struct SymbolInfo::BacktraceInfo
- const char *m_func_name ;
- unsigned int m_lineno ;
- unsigned int m_is_found ;
--
-+
- static void Callback( bfd *abfd, asection *section, void* addr ) ;
- } ;
-
-@@ -117,17 +117,24 @@ void SymbolInfo::BacktraceInfo::Callback( bfd *abfd, asection *section,
- BacktraceInfo *info = (BacktraceInfo *)data ;
- if ((section->flags & SEC_ALLOC) == 0)
- return ;
--
-- bfd_vma vma = bfd_get_section_vma(abfd, section);
--
-+
-+ // bfd_get_section_vma works up to 7b1cfbcf1a27951fb1b3a212995075dd6fdf985b,
-+ // removed in 7c13bc8c91abf291f0206b6608b31955c5ea70d8 (binutils 2.33.1 or so)
-+ // so it's substituted by its implementation to avoid checking for binutils
-+ // version (which at least on Debian SID it's not that easy because the
-+ // version.h is not included with the official package)
-+ bfd_vma vma = section->vma;
-+
- unsigned long address = (unsigned long)(info->m_addr);
- if ( address < vma )
- return;
--
-- bfd_size_type size = bfd_section_size(abfd, section);
-+
-+ // bfd_section_size changed between the two objects described above,
-+ // same rationale applies
-+ bfd_size_type size = section->size;
- if ( address > (vma + size))
- return ;
--
-+
- const SymbolInfo *pthis = info->m_pthis ;
- info->m_is_found = bfd_find_nearest_line( abfd, section,
- pthis->m_impl->m_symbols,
-@@ -149,7 +156,7 @@ void SymbolInfo::PrintTrace( void *addr, std::ostream& os, std::size_t idx )
- {
- this, addr, 0, 0, 0, false
- } ;
--
-+
- Dl_info sym ;
- bfd_map_over_sections( m_impl->m_bfd,
- &SymbolInfo::BacktraceInfo::Callback,
-@@ -165,7 +172,7 @@ if ( btinfo.m_is_found )
- filename.erase( pos, std::strlen( SRC_DIR ) ) ;
- #endif
- os << "#" << idx << " " << addr << " "
-- << filename << ":" << btinfo.m_lineno
-+ << filename << ":" << btinfo.m_lineno
- << " "
- << (btinfo.m_func_name != 0 ? Demangle(btinfo.m_func_name) : "" )
- << std::endl ;
diff --git a/net-misc/grive/grive-0.5.1-r1.ebuild b/net-misc/grive/grive-0.5.1-r1.ebuild
deleted file mode 100644
index 323a194002ef..000000000000
--- a/net-misc/grive/grive-0.5.1-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/vitalif/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An open source Linux client for Google Drive"
-HOMEPAGE="https://github.com/vitalif/grive2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/expat
- >=dev-libs/json-c-0.11-r1:=
- dev-libs/libgcrypt:0=
- dev-libs/yajl
- || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
- sys-libs/binutils-libs:0=
- sys-libs/glibc
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/299.patch" )
diff --git a/net-misc/grive/grive-0.5.2_pre20200205.ebuild b/net-misc/grive/grive-0.5.2_pre20200205.ebuild
deleted file mode 100644
index fdaaf8147839..000000000000
--- a/net-misc/grive/grive-0.5.2_pre20200205.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
-else
- inherit vcs-snapshot
- COMMIT="ffb744a59b1496f86ec71581345355715d846f7b"
- SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An open source Linux client for Google Drive"
-HOMEPAGE="https://github.com/vitalif/grive2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/expat
- >=dev-libs/json-c-0.11-r1:=
- dev-libs/libgcrypt:0=
- dev-libs/yajl
- || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
- sys-libs/binutils-libs:0=
- sys-libs/glibc
-"
-DEPEND="${RDEPEND}"
diff --git a/net-misc/grive/grive-0.5.2_pre20211128.ebuild b/net-misc/grive/grive-0.5.2_pre20211128.ebuild
deleted file mode 100644
index 82bf739ad8c4..000000000000
--- a/net-misc/grive/grive-0.5.2_pre20211128.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
-else
- inherit vcs-snapshot
- COMMIT="6901fbb169eaae51acb61778760ba2ac019675ae"
- SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An open source Linux client for Google Drive"
-HOMEPAGE="https://github.com/vitalif/grive2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/expat
- >=dev-libs/json-c-0.11-r1:=
- dev-libs/libgcrypt:0=
- dev-libs/yajl
- || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
- sys-libs/binutils-libs:0=
- sys-libs/glibc
-"
-DEPEND="${RDEPEND}"