summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-27 03:43:37 +0100
committerSam James <sam@gentoo.org>2023-05-27 03:44:28 +0100
commit8d3d6ac7e5935463fd877b6b31c3605dbd16af96 (patch)
treeeab31b8a919430a12942d7b1aab68d57fa28b7c4
parentmedia-video/vlc: rebase live patches (diff)
downloadgentoo-8d3d6ac7e5935463fd877b6b31c3605dbd16af96.tar.gz
gentoo-8d3d6ac7e5935463fd877b6b31c3605dbd16af96.tar.bz2
gentoo-8d3d6ac7e5935463fd877b6b31c3605dbd16af96.zip
dev-python/ruamel-yaml-clib: fix cythonize call to always regenerate
Ionen took a look and ended up spotting that it wasn't really regenerating it (and that the Clang 16 patch is touching only the generated sources, so is being overwritten now). Also, while here, I noticed it doesn't respect MAKEOPTS, so fix that. Now Python 3.12 builds again. Bug: https://bugs.gentoo.org/880651 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/ruamel-yaml-clib/files/ruamel-yaml-clib-0.2.7-clang-16.patch34
-rw-r--r--dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.7.ebuild8
2 files changed, 2 insertions, 40 deletions
diff --git a/dev-python/ruamel-yaml-clib/files/ruamel-yaml-clib-0.2.7-clang-16.patch b/dev-python/ruamel-yaml-clib/files/ruamel-yaml-clib-0.2.7-clang-16.patch
deleted file mode 100644
index bf4200c15ea0..000000000000
--- a/dev-python/ruamel-yaml-clib/files/ruamel-yaml-clib-0.2.7-clang-16.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://bugs.gentoo.org/880651
-https://sourceforge.net/p/ruamel-yaml-clib/code/merge-requests/3/
-
---- a/_ruamel_yaml.c
-+++ b/_ruamel_yaml.c
-@@ -1553,8 +1553,8 @@
- static PyTypeObject *__pyx_ptype_12_ruamel_yaml_Mark = 0;
- static PyTypeObject *__pyx_ptype_12_ruamel_yaml_CParser = 0;
- static PyTypeObject *__pyx_ptype_12_ruamel_yaml_CEmitter = 0;
--static int __pyx_f_12_ruamel_yaml_input_handler(void *, char *, int, int *); /*proto*/
--static int __pyx_f_12_ruamel_yaml_output_handler(void *, char *, int); /*proto*/
-+static int __pyx_f_12_ruamel_yaml_input_handler(void *, unsigned char *, unsigned long, unsigned long *); /*proto*/
-+static int __pyx_f_12_ruamel_yaml_output_handler(void *, unsigned char *, unsigned long); /*proto*/
- static PyObject *__pyx_f_12_ruamel_yaml___pyx_unpickle_Mark__set_state(struct __pyx_obj_12_ruamel_yaml_Mark *, PyObject *); /*proto*/
- #define __Pyx_MODULE_NAME "_ruamel_yaml"
- extern int __pyx_module_is_main__ruamel_yaml;
-@@ -14551,7 +14551,7 @@
- * parser = <CParser>data
- */
-
--static int __pyx_f_12_ruamel_yaml_input_handler(void *__pyx_v_data, char *__pyx_v_buffer, int __pyx_v_size, int *__pyx_v_read) {
-+static int __pyx_f_12_ruamel_yaml_input_handler(void *__pyx_v_data, unsigned char *__pyx_v_buffer, unsigned long __pyx_v_size, unsigned long *__pyx_v_read) {
- struct __pyx_obj_12_ruamel_yaml_CParser *__pyx_v_parser = 0;
- PyObject *__pyx_v_value = NULL;
- int __pyx_r;
-@@ -23430,7 +23430,7 @@
- * emitter = <CEmitter>data
- */
-
--static int __pyx_f_12_ruamel_yaml_output_handler(void *__pyx_v_data, char *__pyx_v_buffer, int __pyx_v_size) {
-+static int __pyx_f_12_ruamel_yaml_output_handler(void *__pyx_v_data, unsigned char *__pyx_v_buffer, unsigned long __pyx_v_size) {
- struct __pyx_obj_12_ruamel_yaml_CEmitter *__pyx_v_emitter = 0;
- PyObject *__pyx_v_value = NULL;
- int __pyx_r;
diff --git a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.7.ebuild b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.7.ebuild
index 01025ef409a9..affc2ec8b558 100644
--- a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.7.ebuild
+++ b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.7.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
MY_PN="${PN//-/.}"
MY_P="${MY_PN}-${PV}"
@@ -30,15 +30,11 @@ BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2.7-clang-16.patch
-)
-
src_unpack() {
default
mv "${MY_P}" ruamel_yaml_clib || die
}
src_configure() {
- cythonize -3 _ruamel_yaml.pyx || die
+ cythonize -3 _ruamel_yaml.pyx "-j$(makeopts_jobs)" -f || die
}