summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-24 20:07:42 +0100
committerSam James <sam@gentoo.org>2024-04-24 20:07:52 +0100
commita043c51e799c86d2a15b4ff636c4e5345eae3bf3 (patch)
tree357b610bd9e304d2366c26dfe094f0350aa84fa7
parentdev-db/myodbc: add 8.0.32, fix GCC 14 error, EAPI bump (diff)
downloadgentoo-a043c51e799c86d2a15b4ff636c4e5345eae3bf3.tar.gz
gentoo-a043c51e799c86d2a15b4ff636c4e5345eae3bf3.tar.bz2
gentoo-a043c51e799c86d2a15b4ff636c4e5345eae3bf3.zip
dev-db/myodbc: don't install test dir
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/myodbc/myodbc-8.0.32.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-db/myodbc/myodbc-8.0.32.ebuild b/dev-db/myodbc/myodbc-8.0.32.ebuild
index 4b81f9c17da2..942a50b491f7 100644
--- a/dev-db/myodbc/myodbc-8.0.32.ebuild
+++ b/dev-db/myodbc/myodbc-8.0.32.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,6 +12,7 @@ MY_P="${MY_PN}-${PV/_p/r}-src"
DESCRIPTION="ODBC driver for MySQL"
HOMEPAGE="https://dev.mysql.com/downloads/connector/odbc/"
SRC_URI="https://dev.mysql.com/get/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="${MAJOR}"
@@ -22,22 +23,21 @@ RDEPEND="
>=dev-db/mysql-connector-c-8.0:0=[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${MY_P}
# Careful!
DRIVER_NAME="${PN}-${SLOT}"
-# Patch document path so it doesn't install files to /usr
PATCHES=(
+ # Patch document path so it doesn't install files to /usr
"${FILESDIR}/${MAJOR}-cmake-doc-path.patch"
"${FILESDIR}/${PN}-8.0.19-cxxlinkage.patch"
"${FILESDIR}/${PN}-8.0.32-include-string.patch"
)
src_prepare() {
- # Remove Tests
+ # Remove tests
sed -i -e "s/ADD_SUBDIRECTORY(test)//" \
- "${S}/CMakeLists.txt"
+ "${S}/CMakeLists.txt" || die
cmake_src_prepare
}
@@ -70,6 +70,8 @@ multilib_src_configure() {
multilib_src_install_all() {
debug-print-function ${FUNCNAME} "$@"
+ rm -rf "${ED}"/usr/test || die
+
dodir /usr/share/${PN}-${SLOT}
for i in odbc.ini odbcinst.ini; do
einfo "Building $i"