summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 16:56:16 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 17:01:32 +0100
commita14eab8f5cdaa5ca332f703bd72ec27afc5f0134 (patch)
tree8aca6bccb8a9e4a82500a4604c69c18fd99a817a
parentprofiles: mask www-misc/xxv, x11-themes/xxv-skins for removal (diff)
downloadgentoo-a14eab8f5cdaa5ca332f703bd72ec27afc5f0134.tar.gz
gentoo-a14eab8f5cdaa5ca332f703bd72ec27afc5f0134.tar.bz2
gentoo-a14eab8f5cdaa5ca332f703bd72ec27afc5f0134.zip
x11-themes/gtk-engines-murrine: update EAPI 5 -> 7
HOMEPAGE now points to the Debian tracker page because the upstream site is gone. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild b/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild
new file mode 100644
index 000000000000..dd124f302e19
--- /dev/null
+++ b/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME_ORG_MODULE="murrine"
+
+inherit gnome.org multilib-minimal
+
+DESCRIPTION="Murrine GTK+2 Cairo Engine"
+HOMEPAGE="https://tracker.debian.org/pkg/gtk2-engines-murrine"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+themes animation-rtl"
+
+RDEPEND=">=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30.7:2[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.14-r4[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}]
+ >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]"
+PDEPEND="themes? ( x11-themes/murrine-themes )"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/intltool-0.37.1
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS TODO )
+
+src_prepare() {
+ default
+ # Linking fix, in next release (commit 6e8eb244). Sed to avoid eautoreconf.
+ sed -e 's:\($(GTK_LIBS) $(pixman_LIBS)\)$:\1 -lm:' \
+ -i Makefile.* || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf --enable-animation \
+ --enable-rgba \
+ $(use_enable animation-rtl animationrtl)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}