summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-04-01 18:06:53 +0300
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:46 +0300
commitac799e5b6e4ee7b2a69bd9f69210a2fbaefe82dc (patch)
tree15bf3dc699f88530f6f9282e33c3d6b7297a62b0
parentmedia-libs/gstreamer-editing-services: add 1.22.11, EAPI-8, enable py3.12 (diff)
downloadgentoo-ac799e5b6e4ee7b2a69bd9f69210a2fbaefe82dc.tar.gz
gentoo-ac799e5b6e4ee7b2a69bd9f69210a2fbaefe82dc.tar.bz2
gentoo-ac799e5b6e4ee7b2a69bd9f69210a2fbaefe82dc.zip
media-plugins/gst-plugins-vaapi: add 1.22.11, EAPI-8, touchups
Default-enable gles2 instead of opengl to match gst-plugins-base changes. Fix wayland USE requirements. With EAPI-8, python-any-r1 is handled by eclass, also adding py3.12 support. Closes: https://bugs.gentoo.org/842132 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--media-plugins/gst-plugins-vaapi/Manifest2
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild (renamed from media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.10.ebuild)10
2 files changed, 5 insertions, 7 deletions
diff --git a/media-plugins/gst-plugins-vaapi/Manifest b/media-plugins/gst-plugins-vaapi/Manifest
index 597bb0aafa50..723850fe5aee 100644
--- a/media-plugins/gst-plugins-vaapi/Manifest
+++ b/media-plugins/gst-plugins-vaapi/Manifest
@@ -1,3 +1,3 @@
DIST gstreamer-vaapi-1.20.5.tar.xz 801628 BLAKE2B 4c3203baefafccbf8983c9e1da17a3455a0566d27b9a12b4d30292289cded803fb4ae8de1f26ff3536c632984227809df69fa9de78af4190acc30b6750c2d27c SHA512 fd24a58c83b0f820b1b2ca3c179228574a16b9f2657988de0c4569d925f01eb131853b0a322ce95b8523578e66ca66443900af1a5e022ecb4081bfe86a2e23bc
DIST gstreamer-vaapi-1.20.6.tar.xz 801364 BLAKE2B 891e84099a558b31a152b6be2062753201a3958ce5fb67af37525c7b548404636cfeaa9578cdd485fbaddfabfd929f008ea07d0107975cc8174c58e38e791311 SHA512 3c386400b90ce7a90c0bec2244f0ef1a069cea053915abad3803e67ef7b859276f91a859ba1c959aedbfcb395058a0b0d917e9dd2f148b1cc038469996388af3
-DIST gstreamer-vaapi-1.22.10.tar.xz 551620 BLAKE2B b4ca3aad753b54eab78d7cd9fe877aa155c75e8e29a183d895ec6187dd4b05ef4d159ac387f434c94cedb49d75aea13e423ab5ec3e256838d85c89fef298f8b6 SHA512 80ba190efb2aeaedbcb25a9f8d7401a6bc05a112f4e0a9bcebcc04dd2b8782c2a6799901312b77d565122766405375eae22e838a3e4d688005cec0f756232b07
+DIST gstreamer-vaapi-1.22.11.tar.xz 552468 BLAKE2B 0353699651add70639a4f7d591eccb646f5d6cda3ba8832553597b7b4e9bd3ebfe07d9eb1ac6e078219ee630131d502adccc8106a2207bb0234353905bafd8cd SHA512 939b748fea88c94ad59c1d4610a872a794b383382096a8f5f011a21d4c8fb041c28e1aa9a8d54f519fb3e48a69ed79622b0d45be01d2d5a900738a7928401563
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.10.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild
index df1c1b7f01be..8f7698e27087 100644
--- a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.10.ebuild
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit gstreamer-meson python-any-r1
+EAPI=8
+inherit gstreamer-meson
MY_PN="gstreamer-vaapi"
DESCRIPTION="Hardware accelerated video decoding through VA-API plugin for GStreamer"
@@ -14,7 +12,7 @@ SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
LICENSE="LGPL-2.1+"
SLOT="1.0"
KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
-IUSE="+drm +egl gles2 +opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
+IUSE="+drm +egl +gles2 opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
# gst-vaapi configure is based around GL platform mainly, unlike gst-plugins-bad that goes by GL API mainly; for less surprises,
# we design gst-vaapi ebuild in terms of GL API as main choice as well, meaning that USE opengl and/or gles2 is required to
@@ -29,6 +27,7 @@ REQUIRED_USE="
|| ( drm gles2 opengl wayland X )
gles2? ( egl )
opengl? ( || ( egl X ) )
+ wayland? ( drm )
"
# glx doesn't require libva-glx (libva[opengl]) afaics, only by tests/test-display.c
@@ -64,7 +63,6 @@ RDEPEND="
x11-libs/libXrender[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
S="${WORKDIR}/${MY_PN}-${PV}"