summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-04-17 14:30:14 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-17 16:11:30 +0200
commitadf46516063fda9fd9fbc399097c84ae652fdafe (patch)
tree07b672074e3ff142d925a3b1b896baba8fc19e43
parentdev-libs/intel-compute-runtime: amd64 stable (diff)
downloadgentoo-adf46516063fda9fd9fbc399097c84ae652fdafe.tar.gz
gentoo-adf46516063fda9fd9fbc399097c84ae652fdafe.tar.bz2
gentoo-adf46516063fda9fd9fbc399097c84ae652fdafe.zip
dev-libs/intel-compute-runtime: drop 23.52.28202.23-r1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-23.52.28202.23-r1.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index b0f0cba857ae..701d922124c8 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1 @@
-DIST intel-compute-runtime-23.52.28202.23.tar.gz 6903413 BLAKE2B ecd16511fc8065cc8e09827a1b333a5d8caa1ec0c815de21b90d896a5d1e6c8225423e748005b5f6012eb0c68da08cf06abaf8431709145bb329a3dd34270222 SHA512 aa33b712af2526f94a3d8508edb3201203c34bf90b0125ed9b9878539066baaedd9b9e1c464b760c38c159b4b4aa3671465ba90c2bdd58626f578e92957093fa
DIST intel-compute-runtime-24.05.28454.17.tar.gz 6963009 BLAKE2B ca4840dedbea06bba7933ba74658eee602a6de19d35ec4baac1d41d5eb3041f16a4e7e82072f98961d19d2e7f97b9f3ad698ff84532f009537d23d7970162fc5 SHA512 f70967c649e7a17eab7fa550a2b344333357717021c16e3116eb47be45ea806bb0fc64795dad21027e7f055318f1e05c9e726c3e735dc3b7336de1839f6eae8e
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.52.28202.23-r1.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-23.52.28202.23-r1.ebuild
deleted file mode 100644
index 69877d079fea..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.52.28202.23-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND="
- >=dev-util/intel-graphics-compiler-1.0.15136.4
- >=media-libs/gmmlib-22.3.5:=
-"
-
-DEPEND="
- ${RDEPEND}
- dev-libs/intel-metrics-discovery:=
- dev-libs/intel-metrics-library:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-system-controller-0.8.13:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.14.0:= )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- media-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=(
- "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
-)
-
-src_prepare() {
- # Remove '-Werror' from default
- sed -e '/Werror/d' -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-lto
-
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}