summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-03-09 18:34:25 +0100
committerMichael Weber <xmw@gentoo.org>2017-03-09 18:43:43 +0100
commitba07d24672f6a542fbc9edaa35742c7771486960 (patch)
tree229548906d363897d39589adc5af7c2fcc596df9
parentapp-cdr/k3b -> kde-apps/k3b (diff)
downloadgentoo-ba07d24672f6a542fbc9edaa35742c7771486960.tar.gz
gentoo-ba07d24672f6a542fbc9edaa35742c7771486960.tar.bz2
gentoo-ba07d24672f6a542fbc9edaa35742c7771486960.zip
x11-wm/xpra: activate tmpfiles.d file in pkg_postinst.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--x11-wm/xpra/xpra-1.0.3-r1.ebuild (renamed from x11-wm/xpra/xpra-1.0.3.ebuild)13
1 files changed, 8 insertions, 5 deletions
diff --git a/x11-wm/xpra/xpra-1.0.3.ebuild b/x11-wm/xpra/xpra-1.0.3-r1.ebuild
index 7116a9ce4acd..97f5c0e644f6 100644
--- a/x11-wm/xpra/xpra-1.0.3.ebuild
+++ b/x11-wm/xpra/xpra-1.0.3-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 compat
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils flag-o-matic user
+inherit distutils-r1 eutils flag-o-matic user tmpfiles
DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
@@ -85,16 +85,19 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
>=dev-python/cython-0.16[${PYTHON_USEDEP}]"
+PATCHES=( "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch
+ "${FILESDIR}"/${PN}-0.17.4-deprecated-avcodec.patch )
+
pkg_postinst() {
enewgroup ${PN}
+ tmpfiles_process /usr/lib/tmpfiles.d/xpra.conf
}
python_prepare_all() {
rm -rf rencode || die
- epatch \
- "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.17.4-deprecated-avcodec.patch
+ sed -e "s:/var/run/xpra:${EROOT}run/xpra:" \
+ -i tmpfiles.d/xpra.conf
if use libav ; then
if ! has_version ">=media-video/libav-9" ; then