summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-16 17:00:45 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-16 17:00:45 +0200
commitbbae26277dd01e34f6b6cf2bd0f2902a69132d92 (patch)
tree66ab2771dbd4bd56ae6ba8c5db56dd3c405a65a2
parentdev-python/pyGPG: Update live ebuild (diff)
downloadgentoo-bbae26277dd01e34f6b6cf2bd0f2902a69132d92.tar.gz
gentoo-bbae26277dd01e34f6b6cf2bd0f2902a69132d92.tar.bz2
gentoo-bbae26277dd01e34f6b6cf2bd0f2902a69132d92.zip
dev-python/pyGPG: Add py3.7
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/pyGPG/pyGPG-0.2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/pyGPG/pyGPG-0.2.ebuild b/dev-python/pyGPG/pyGPG-0.2.ebuild
index a6a797b30f4d..e3d575a7cd70 100644
--- a/dev-python/pyGPG/pyGPG-0.2.ebuild
+++ b/dev-python/pyGPG/pyGPG-0.2.ebuild
@@ -1,24 +1,28 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
-EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+fi
DESCRIPTION="A python interface wrapper for gnupg's gpg command"
HOMEPAGE="https://github.com/dol-sen/pyGPG"
-SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
IUSE=""
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
-
DEPEND=""
RDEPEND="${DEPEND}
app-crypt/gnupg